toolchain: fix dangling symlink to self in FixupLibdir
authorSven Wegener <sven.wegener@stealer.net>
Thu, 17 Dec 2015 10:59:24 +0000 (11:59 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 1 Jul 2022 17:17:36 +0000 (19:17 +0200)
This avoids a dangling symlink to self when reinstalling the toolchain:

./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib/lib -> lib

This is caused by the fact that in the toolchain dir we have

'lib64 -> lib'

and on executing

'ln lib ./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib64'

ln dereference the symbolic link 'lib64' to 'lib' so the REAL command is

'ln lib ./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib'

this results in the dangling symlink to self.

Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
[ add more details to the commit description and fix title ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/toolchain-build.mk

index b7a253b71b892617c0337a0fe6d4455489259e57..87ba8313df189a604ce1ff44d9bb0bb44936fd10 100644 (file)
@@ -18,6 +18,6 @@ define FixupLibdir
                mkdir -p $(1)/lib; \
                mv $(1)/lib64/* $(1)/lib/; \
                rm -rf $(1)/lib64; \
+               ln -sf lib $(1)/lib64; \
        fi
-       ln -sf lib $(1)/lib64
 endef