uboot-zynq: Fix build with libressl 2.7.2
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 28 Apr 2018 22:39:38 +0000 (00:39 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 28 Apr 2018 22:57:35 +0000 (00:57 +0200)
When libressl was linked the libpthread was missing, add it in addition.

Fixes: 2c192b69163f ("tools/libressl: update to version 2.7.2")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch [new file with mode: 0644]

diff --git a/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch b/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
new file mode 100644 (file)
index 0000000..a260e84
--- /dev/null
@@ -0,0 +1,14 @@
+OpenWrt links the libressl statically against mkimage, make sure all the 
+needed dependencies are added too.
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -128,7 +128,7 @@ endif
+ # MXSImage needs LibSSL
+ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_FIT_SIGNATURE),)
+ HOSTLOADLIBES_mkimage += \
+-      $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
++      $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
+ # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
+ # warnings on those systems