kernel: remove stmmac kernel package
authorJohn Crispin <john@openwrt.org>
Mon, 1 Jun 2015 20:11:45 +0000 (20:11 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 1 Jun 2015 20:11:45 +0000 (20:11 +0000)
We just moved the stmmac support in the kernel for ipq806x. Therefore,
nobody needs this driver so we'll just get rid of it.

Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
SVN-Revision: 45872

package/kernel/linux/modules/netdevices.mk

index c7a11e76d6d37ac63f6959fc6556829169ba177c..9dd18f311f287f505c2120cc05ace42c773a32a3 100644 (file)
@@ -811,27 +811,6 @@ endef
 $(eval $(call KernelPackage,vmxnet3))
 
 
-define KernelPackage/stmmac
-  SUBMENU:=$(NETWORK_DEVICES_MENU)
-  TITLE:=STMicro 10/100/1000 Ethernet driver
-  DEPENDS:=+kmod-mii +kmod-ptp +kmod-libphy
-  KCONFIG:=CONFIG_NET_VENDOR_STMICRO=y \
-         CONFIG_STMMAC_ETH \
-         CONFIG_STMMAC_PLATFORM=y \
-         CONFIG_STMMAC_DEBUG_FS=y \
-         CONFIG_STMMAC_DA=y \
-         CONFIG_DWMAC_IPQ806X=y
-  FILES:=$(LINUX_DIR)/drivers/net/ethernet/stmicro/stmmac/stmmac.ko
-  AUTOLOAD:=$(call AutoLoad,50,stmmac.ko)
-endef
-
-define KernelPackage/stmmac/description
-  Kernel module for STMicroelectronics 10/100/1000 Ethernet driver
-endef
-
-$(eval $(call KernelPackage,stmmac))
-
-
 define KernelPackage/spi-ks8995
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Micrel/Kendin KS8995 Ethernet switch control