image: introduce MkuImageARM function
authorLuka Perkov <luka@openwrt.org>
Sun, 13 Oct 2013 03:35:14 +0000 (03:35 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 13 Oct 2013 03:35:14 +0000 (03:35 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38380

include/image.mk

index aa3bf27de06d1e856a294b9e15a816caf9f97e33..67cfa4b677c2de74ee311b8575e0de7affda2feb 100644 (file)
@@ -82,6 +82,11 @@ else
   endef
 endif
 
+define Image/BuildKernel/MkuImageARM
+       mkimage -A arm -O linux -T kernel -a $(1) -C none -e $(1) \
+               -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(2) $(3)
+endef
+
 define Image/mkfs/jffs2/sub
                # FIXME: removing this line will cause strange behaviour in the foreach loop below
                $(STAGING_DIR_HOST)/bin/mkfs.jffs2 $(3) --pad -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(2) -d $(TARGET_DIR) -v 2>&1 1>/dev/null | awk '/^.+$$$$/'