valgrind: fix build failure on uml
authorNicolas Thill <nico@openwrt.org>
Wed, 20 Aug 2014 13:58:23 +0000 (13:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 20 Aug 2014 13:58:23 +0000 (13:58 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 42229

package/devel/valgrind/Makefile

index 26dcf0b5c98cf27d68ce8db91cbdb01f945d78d6..f3c021c6c45c6459a5081aaa46ae6368e0d4775c 100644 (file)
@@ -77,7 +77,7 @@ define Package/valgrind/description
        to speed up and reduce memory use of your programs.
 endef
 
-CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(LINUX_KARCH)))
+CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(patsubst um,$(ARCH),$(LINUX_KARCH))))
 
 CONFIGURE_VARS += \
        UNAME_R=$(LINUX_VERSION)