call autoconf when there's no ./configure script, move it at Build/Prepare stage
authorNicolas Thill <nico@openwrt.org>
Thu, 25 Sep 2008 10:47:39 +0000 (10:47 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 25 Sep 2008 10:47:39 +0000 (10:47 +0000)
SVN-Revision: 12693

package/bridge-utils/Makefile

index c771ab7cb59ad65609b8bbf7c1953788ee31286a..e45bcb0f0be6fbd7deb484462c5b01a511f2bcdd 100644 (file)
@@ -42,11 +42,13 @@ endef
 CONFIGURE_ARGS += \
        --with-linux-headers="$(LINUX_DIR)" \
 
 CONFIGURE_ARGS += \
        --with-linux-headers="$(LINUX_DIR)" \
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       [ "$(PKG_VERSION)" = "1.0.6" ] || ln -s configure.in configure.ac; \
-       autoconf; \
-       ./configure $(CONFIGURE_ARGS) \
+define Build/Prepare
+$(call Build/Prepare/Default)
+       ( cd $(PKG_BUILD_DIR) ; \
+               [ -f ./configure ] || { \
+                       ln -sf configure.in configure.ac ; \
+                       autoconf ; \
+               } \
        )
 endef
 
        )
 endef