ath79: add support for NEC Aterm WG1200CR
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Sat, 16 Mar 2019 04:27:32 +0000 (13:27 +0900)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 6 Apr 2019 17:14:06 +0000 (19:14 +0200)
NEC Aterm WG1200CR is a 2.4/5 GHz band 11ac router,
based on Qualcomm Atheros QCA9563.

Specification:

- SoC : Qualcomm Atheros QCA9563
- RAM : DDR2 128 MiB
- Flash : SPI-NOR 8 MiB
- WLAN : 2.4/5 GHz 2T2R
  - 2.4 GHz : QCA9563 (SoC)
  - 5 GHz : QCA9888
- Ethernet : 2x 10/100/1000 Mbps
  - Switch : QCA8334
- LEDs/Input : 12x/4x (2x buttons, 1x slide-switch)
- UART : through-hole on PCB
  - JP1: Vcc, GND, NC, TX, RX from power connector side
  - 115200 bps

Flash instruction using factory image:

1. Boot WG1200CR normaly
2. Access to "http://192.168.10.1/" and open firmware update page
("ファームウェア更新")
3. Select the OpenWrt factory image and click update ("更新") button
to perform firmware update
4. Wait ~150 seconds to complete flashing

Known issues:

- cannot be controlled LEDs other than Power (Green/Red)
  - only Power LEDs are connected to SoC GPIO; other LEDs
    connected to the gpiochip on ath10k chip (QCA9888)

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [commit
message formatting]

target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9563_nec_wg1200cr.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index fbf15e4ed8dfb12c13c3589bfa194a43a18d9fcf..e0b777da739a71ebee54f4d386130dadccb17c1f 100755 (executable)
@@ -128,6 +128,13 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "5:wan" "6@eth1" "4:lan"
        ;;
                ucidef_add_switch "switch0" \
                        "0@eth0" "5:wan" "6@eth1" "4:lan"
        ;;
+       nec,wg1200cr|\
+       ubnt,nanostation-ac|\
+       ubnt,unifiac-mesh-pro|\
+       ubnt,unifiac-pro)
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "2:lan" "3:wan"
+               ;;
        nec,wg800hp)
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan" "3:lan" "4:lan" "1:wan"
        nec,wg800hp)
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan" "3:lan" "4:lan" "1:wan"
@@ -234,12 +241,6 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "5:lan" "1:wan"
                ;;
                ucidef_add_switch "switch0" \
                        "0@eth0" "5:lan" "1:wan"
                ;;
-       ubnt,nanostation-ac|\
-       ubnt,unifiac-mesh-pro|\
-       ubnt,unifiac-pro)
-               ucidef_add_switch "switch0" \
-                       "0@eth0" "2:lan" "3:wan"
-               ;;
        xiaomi,mi-router-4q)
                ucidef_set_interface_wan "eth0"
                ucidef_add_switch "switch0" \
        xiaomi,mi-router-4q)
                ucidef_set_interface_wan "eth0"
                ucidef_add_switch "switch0" \
@@ -272,7 +273,8 @@ ath79_setup_macs()
                lan_mac=$(mtd_get_mac_text "mac" 4)
                wan_mac=$(mtd_get_mac_text "mac" 24)
                ;;
                lan_mac=$(mtd_get_mac_text "mac" 4)
                wan_mac=$(mtd_get_mac_text "mac" 24)
                ;;
-       dlink,dir-859-a1)
+       dlink,dir-859-a1|\
+       nec,wg1200cr)
                lan_mac=$(mtd_get_mac_ascii devdata "lanmac")
                wan_mac=$(mtd_get_mac_ascii devdata "wanmac")
                ;;
                lan_mac=$(mtd_get_mac_ascii devdata "lanmac")
                wan_mac=$(mtd_get_mac_ascii devdata "wanmac")
                ;;
index 72a768c554f347d9a3675e20416767aabe91a30a..90f8ca96d62440243da3b15d541fe108d2aac8b4 100644 (file)
@@ -117,6 +117,10 @@ case "$FIRMWARE" in
                ath9k_eeprom_extract "art" 4096 1088
                ath9k_patch_fw_mac $(mtd_get_mac_ascii u-boot-env ethaddr) 2
                ;;
                ath9k_eeprom_extract "art" 4096 1088
                ath9k_patch_fw_mac $(mtd_get_mac_ascii u-boot-env ethaddr) 2
                ;;
+       nec,wg1200cr)
+               ath9k_eeprom_extract "art" 4096 1088
+               ath9k_patch_fw_mac $(mtd_get_mac_ascii devdata wlan24mac) 2
+               ;;
        nec,wg800hp)
                ath9k_eeprom_extract "art" 4096 1088
                ath9k_patch_fw_mac $(mtd_get_mac_text board_data 1664) 2
        nec,wg800hp)
                ath9k_eeprom_extract "art" 4096 1088
                ath9k_patch_fw_mac $(mtd_get_mac_text board_data 1664) 2
index 4f13ae6521bf18cd9f495d6c76b1ff6a9de9aa27..8766862bb639ade133e977f8e09d2183091c784b 100644 (file)
@@ -163,6 +163,12 @@ case "$FIRMWARE" in
        ;;
 "ath10k/pre-cal-pci-0000:00:00.0.bin")
        case $board in
        ;;
 "ath10k/pre-cal-pci-0000:00:00.0.bin")
        case $board in
+       nec,wg1200cr)
+               ath10kcal_extract "art" 20480 12064
+               ath10kcal_patch_mac_crc $(mtd_get_mac_ascii devdata wlan5mac)
+               ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
+                       /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
+               ;;
        phicomm,k2t)
                ath10kcal_extract "art" 20480 12064
                ath10kcal_patch_mac_crc $(k2t_get_mac "5g_mac")
        phicomm,k2t)
                ath10kcal_extract "art" 20480 12064
                ath10kcal_patch_mac_crc $(k2t_get_mac "5g_mac")
diff --git a/target/linux/ath79/dts/qca9563_nec_wg1200cr.dts b/target/linux/ath79/dts/qca9563_nec_wg1200cr.dts
new file mode 100644 (file)
index 0000000..8c356bd
--- /dev/null
@@ -0,0 +1,176 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       model = "NEC Aterm WG1200CR";
+       compatible = "nec,wg1200cr", "qca,qca9563";
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &power_green;
+               led-failsafe = &power_red;
+               led-running = &power_green;
+               led-upgrade = &power_green;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+               /* other LEDs are connected to ath10k (QCA9888) gpiochip */
+
+               power_green: power_green {
+                       label = "wg1200cr:green:power";
+                       gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               power_red: power_red {
+                       label = "wg1200cr:red:power";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+                       debounce-interval = <60>;
+               };
+
+               bridge {
+                       label = "br";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+                       debounce-interval = <60>;
+               };
+
+               converter {
+                       label = "cnv";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+                       debounce-interval = <60>;
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "devdata";
+                               reg = <0x040000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               label = "devconf";
+                               reg = <0x050000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "misc";
+                               reg = <0x060000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@70000 {
+                               label = "wifimngdata";
+                               reg = <0x070000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               compatible = "seama";
+                               label = "firmware";
+                               reg = <0x080000 0x770000>;
+                       };
+
+                       partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+
+               qca,ar8327-initvals = <
+                       0x04 0x00000080 /* PORT0 PAD MODE CTRL */
+                       0x50 0xcc35cc35 /* LED_CTRL0 */
+                       0x54 0xca35ca35 /* LED_CTRL1 */
+                       0x58 0xc935c935 /* LED_CTRL2 */
+                       0x5c 0x03ffff00 /* LED_CTRL3 */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+               >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       pll-data = <0x03000101 0x00000101 0x00001919>;
+
+       phy-mode = "sgmii";
+       phy-handle = <&phy0>;
+};
+
+&pcie {
+       status = "okay";
+
+       wifi@0,0 {
+               compatible = "pci168c,0056";
+               reg = <0x0000 0 0 0 0>;
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+       qca,no-eeprom;
+};
index 288a6110f67c37c01713a75a04fb17fd6197eeb9..0d5ad171f1eb3a6cf877eb25928878b412559824 100644 (file)
@@ -42,6 +42,12 @@ define Build/add-elecom-factory-initramfs
   fi
 endef
 
   fi
 endef
 
+define Build/nec-enc
+  $(STAGING_DIR_HOST)/bin/nec-enc \
+    -i $@ -o $@.new -k $(1)
+  mv $@.new $@
+endef
+
 define Build/nec-fw
   ( stat -c%s $@ | tr -d "\n" | dd bs=16 count=1 conv=sync; ) >> $@
   ( \
 define Build/nec-fw
   ( stat -c%s $@ | tr -d "\n" | dd bs=16 count=1 conv=sync; ) >> $@
   ( \
@@ -446,6 +452,24 @@ define Device/librerouter_librerouter-v1
 endef
 TARGET_DEVICES += librerouter_librerouter-v1
 
 endef
 TARGET_DEVICES += librerouter_librerouter-v1
 
+define Device/nec_wg1200cr
+  ATH_SOC := qca9563
+  DEVICE_TITLE := NEC Aterm WG1200CR
+  IMAGE_SIZE := 7616k
+  SEAMA_MTDBLOCK := 6
+  SEAMA_SIGNATURE := wrgac72_necpf.2016gui_wg1200cr
+  IMAGES += factory.bin
+  IMAGE/default := \
+    append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
+  IMAGE/sysupgrade.bin := \
+    $$(IMAGE/default) | seama | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+  IMAGE/factory.bin := \
+    $$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | nec-enc 9gsiy9nzep452pad | \
+    check-size $$$$(IMAGE_SIZE)
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+TARGET_DEVICES += nec_wg1200cr
+
 define Device/nec_wg800hp
   ATH_SOC := qca9563
   DEVICE_TITLE := NEC Aterm WG800HP
 define Device/nec_wg800hp
   ATH_SOC := qca9563
   DEVICE_TITLE := NEC Aterm WG800HP