argp-standalone: add host-compile ability
authorSergey V. Lobanov <sergey@lobanov.in>
Sat, 5 Feb 2022 09:41:44 +0000 (12:41 +0300)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 26 Feb 2022 18:52:41 +0000 (19:52 +0100)
This patch adds host-compile ability to argp-standalone for build
hosts without glibc and argp lib, e.g. MacOS.

iucode-tool/host can not be built on MacOS due to lack of argp.

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
package/libs/argp-standalone/Makefile

index 8fad739d85d01b4497b637d3c2c42891ad0646ef..21b154f29d8e3fa14cde9f44afdca4a8a62aa48e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=argp-standalone
 PKG_VERSION:=1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lysator.liu.se/~nisse/misc/
@@ -20,6 +20,7 @@ PKG_LICENSE:=LGPL-2.1
 PKG_LICENSE:=Makefile.am
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/argp-standalone
   SECTION:=libs
@@ -45,4 +46,14 @@ define Build/InstallDev
                $(1)/usr/lib/
 endef
 
+define Host/Install
+       $(INSTALL_DIR) $(1)/include
+       $(CP)   $(HOST_BUILD_DIR)/argp.h \
+               $(1)/include/
+       $(INSTALL_DIR) $(1)/lib
+       $(CP)   $(HOST_BUILD_DIR)/libargp.a \
+               $(1)/lib/
+endef
+
 $(eval $(call BuildPackage,argp-standalone))
+$(eval $(call HostBuild))