firewall: config: remove restictions on DHCPv6 allow rule
authorTiago Gaspar <tiagogaspar8@gmail.com>
Wed, 4 May 2022 09:36:07 +0000 (10:36 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 4 May 2022 13:26:16 +0000 (15:26 +0200)
Remove restrictions on source and destination addresses, which aren't
specified on RFC8415, and for some reason in openwrt are configured
to allow both link-local and ULA addresses.
As cleared out in issue #5066 there are some ISPs that use Gloabal
Unicast addresses, so fix this rule to allow them.

Fixes: #5066
Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
[rebase onto firewall3, clarify subject, bump PKG_RELEASE]
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/config/firewall/Makefile
package/network/config/firewall/files/firewall.config

index 6296837563fa80b3fbbcec73ba35ddd91b35a1ce..9715e1f6bb556995cada5621b2c1d0ffccc3375c 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall3.git
index 5e22f984ce9f9e0ef3bd63f73816356c2dd1d8df..61cfe665e451855c5af8182d35f337fac373a6c3 100644 (file)
@@ -54,13 +54,11 @@ config rule
        option target           ACCEPT
 
 # Allow DHCPv6 replies
-# see https://dev.openwrt.org/ticket/10381
+# see https://github.com/openwrt/openwrt/issues/5066
 config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
-       option src_ip           fc00::/6
-       option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT