gemini: drop Teltonika RUT1xx artifacts
authorMathias Kresin <dev@kresin.me>
Sat, 26 Jan 2019 08:17:41 +0000 (09:17 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 26 Jan 2019 14:23:38 +0000 (15:23 +0100)
Support for the Teltonika RUT1xx was added with the switch to kernel
4.4. Hidding such changes in a kernel switch commit is the wrong way and
the support for the Teltonika RUT1xx is pretty much incomplete.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/gemini/image/Makefile
target/linux/gemini/patches-4.14/0012-ARM-dts-Add-ethernet-PHYs-to-the-a-bunch-of-Geminis.patch
target/linux/gemini/patches-4.14/0031-ARM-dts-Add-the-FOTG210-USB-host-to-Gemini.patch

index aca6e11df2206fa0c104874ba8c7528a70ea015a..14e92ad71da741f8b4ad61d92c6e6d47648d8b7c 100644 (file)
@@ -147,13 +147,6 @@ define Device/raidsonic_ib-4220-b
 endef
 TARGET_DEVICES += raidsonic_ib-4220-b
 
-define Device/teltonika_rut1xx
-       DEVICE_TITLE := Teltonika RUT1xx
-       DEVICE_DTS := gemini-rut1xx
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-endef
-TARGET_DEVICES += teltonika_rut1xx
-
 # The wiliboard images need some changes to be functional and buildable.
 #
 # The dts would need to use the ecoscentric,redboot-fis-partitions partition
index db701e3e9921d487b7437cc63a54dce35d970063..2549ea3151da21239bf938bb85e060c2a8152c24 100644 (file)
@@ -13,7 +13,6 @@ Reviewed-by: Andrew Lunn <andrew@lunn.ch>
 Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
 ---
  arch/arm/boot/dts/gemini-nas4220b.dts | 13 +++++++++++++
- arch/arm/boot/dts/gemini-rut1xx.dts   | 13 +++++++++++++
  arch/arm/boot/dts/gemini-wbd111.dts   | 13 +++++++++++++
  arch/arm/boot/dts/gemini-wbd222.dts   | 18 ++++++++++++++++++
  4 files changed, 57 insertions(+)
@@ -24,28 +23,6 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
                };
        };
  
-+      mdio0: ethernet-phy {
-+              compatible = "virtual,mdio-gpio";
-+              gpios = <&gpio0 22 GPIO_ACTIVE_HIGH>, /* MDC */
-+                      <&gpio0 21 GPIO_ACTIVE_HIGH>; /* MDIO */
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+
-+              phy0: ethernet-phy@1 {
-+                      reg = <1>;
-+                      device_type = "ethernet-phy";
-+              };
-+      };
-+
-       soc {
-               flash@30000000 {
-                       status = "okay";
---- a/arch/arm/boot/dts/gemini-rut1xx.dts
-+++ b/arch/arm/boot/dts/gemini-rut1xx.dts
-@@ -58,6 +58,19 @@
-               };
-       };
 +      mdio0: ethernet-phy {
 +              compatible = "virtual,mdio-gpio";
 +              gpios = <&gpio0 22 GPIO_ACTIVE_HIGH>, /* MDC */
index cb6fdb875257e2360d709739f7a038214983248d..d5544a1cb5f8b798bccc533754ec66806cd006f2 100644 (file)
@@ -19,7 +19,6 @@ the patch is only included in the series for context.
 ---
  arch/arm/boot/dts/gemini-dlink-dir-685.dts |  8 ++++++++
  arch/arm/boot/dts/gemini-nas4220b.dts      |  8 ++++++++
- arch/arm/boot/dts/gemini-rut1xx.dts        | 20 ++++++++++++++++++++
  arch/arm/boot/dts/gemini-wbd111.dts        | 20 ++++++++++++++++++++
  arch/arm/boot/dts/gemini-wbd222.dts        | 21 +++++++++++++++++++++
  arch/arm/boot/dts/gemini.dtsi              | 26 ++++++++++++++++++++++++++
@@ -54,34 +53,6 @@ the patch is only included in the series for context.
 +
 +              usb@69000000 {
 +                      status = "okay";
-+              };
-       };
- };
---- a/arch/arm/boot/dts/gemini-rut1xx.dts
-+++ b/arch/arm/boot/dts/gemini-rut1xx.dts
-@@ -114,5 +114,25 @@
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&gpio1_default_pins>;
-               };
-+
-+              ethernet@60000000 {
-+                      status = "okay";
-+
-+                      ethernet-port@0 {
-+                              phy-mode = "rgmii";
-+                              phy-handle = <&phy0>;
-+                      };
-+                      ethernet-port@1 {
-+                              /* Not used in this platform */
-+                      };
-+              };
-+
-+              usb@68000000 {
-+                      status = "okay";
-+              };
-+
-+              usb@69000000 {
-+                      status = "okay";
 +              };
        };
  };