uboot-mxs: fix build on hosts lacking pkg-config
authorJo-Philipp Wich <jo@mein.io>
Wed, 23 May 2018 07:15:52 +0000 (09:15 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 23 May 2018 07:29:28 +0000 (09:29 +0200)
The uboot-mvebu package incorrectly used the host pkg-config for the tool
build parts, which broke the build on systems lacking pkg-config and only
worked by accident on those that have it installed.

Export the host-build specific environment variables for the uboot build
to redirect pkg-config invocations to our staged host build pkg-config in
buildroot.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 208b984dda0c2348d425b992b9a1c171d5aaa8e8)

package/boot/uboot-mxs/Makefile

index cd752bb81a3250c1e11fb0669bbeff8d02fc01f3..5636dcfbb46ddab2ce006aaeee2cd82533e22a17 100644 (file)
@@ -15,6 +15,7 @@ PKG_HASH:=6a018fd3caf58f3dcfa23ee989a82bd35df03af71872b9dca8c6d758a0d26c05
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define U-Boot/Default
   BUILD_TARGET:=mxs
@@ -37,6 +38,8 @@ UBOOT_TARGETS := \
 
 UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)
 
+Build/Exports:=$(Host/Exports)
+
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)