kernel: update 3.9 to 3.9.11
authorGabor Juhos <juhosg@openwrt.org>
Mon, 22 Jul 2013 15:30:56 +0000 (15:30 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 22 Jul 2013 15:30:56 +0000 (15:30 +0000)
Also refresh 3.9 patches.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 37501

include/kernel-version.mk
target/linux/ar7/Makefile
target/linux/brcm63xx/Makefile
target/linux/gemini/Makefile
target/linux/generic/patches-3.9/644-bridge_optimize_netfilter_hooks.patch
target/linux/lantiq/patches-3.9/0010-NET-MIPS-lantiq-update-etop-driver-for-devicetree.patch

index 0e7311b69d2b4ea91e4b5dbb501b4a380f0b9641..188157a52200d363a68906facc75130a9b10baa5 100644 (file)
@@ -14,8 +14,8 @@ endif
 ifeq ($(LINUX_VERSION),3.8.13)
   LINUX_KERNEL_MD5SUM:=2af19d06cd47ec459519159cdd10542d
 endif
 ifeq ($(LINUX_VERSION),3.8.13)
   LINUX_KERNEL_MD5SUM:=2af19d06cd47ec459519159cdd10542d
 endif
-ifeq ($(LINUX_VERSION),3.9.10)
-  LINUX_KERNEL_MD5SUM:=2d69615f7074b952cfcb65f1356c0cc9
+ifeq ($(LINUX_VERSION),3.9.11)
+  LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
 endif
 ifeq ($(LINUX_VERSION),3.10.1)
   LINUX_KERNEL_MD5SUM:=4c8ed240943c8750a89cc307637bd74d
 endif
 ifeq ($(LINUX_VERSION),3.10.1)
   LINUX_KERNEL_MD5SUM:=4c8ed240943c8750a89cc307637bd74d
index 1ee72ae4e9a05bcdd80188fcad7ffe7b47da81de..f4bac3c6d85fc76e02eda9d46bfb46c926981789 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs atm
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 SUBTARGETS:=generic ac49x
 
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=3.9.10
+LINUX_VERSION:=3.9.11
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index c2cbdf6c3671167d0a684e27b47302c058ca48c4..e76e152f0f00b332fd2aef4a3369db86960b5dee 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.9.10
+LINUX_VERSION:=3.9.11
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index daa46889a3b792a69a7f65ba46302972201f22a4..f0e802dba8584a25ab277ed9fc1a6328ff82c52f 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs pci
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.9.10
+LINUX_VERSION:=3.9.11
 
 KERNELNAME:="zImage"
 
 
 KERNELNAME:="zImage"
 
index 986b3f843b829917b527410a736f362bf02c2607..64a980ebdddfe4223f2adc99690990ecd0880b98 100644 (file)
@@ -48,8 +48,8 @@
                        return RX_HANDLER_CONSUMED; /* consumed by filter */
                } else {
 @@ -224,7 +224,7 @@ forward:
                        return RX_HANDLER_CONSUMED; /* consumed by filter */
                } else {
 @@ -224,7 +224,7 @@ forward:
-               if (!ether_addr_equal(p->br->dev->dev_addr, dest))
-                       goto drop;
+               if (ether_addr_equal(p->br->dev->dev_addr, dest))
+                       skb->pkt_type = PACKET_HOST;
  
 -              if (NF_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
 +              if (BR_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
  
 -              if (NF_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
 +              if (BR_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
index adf34c9b192fde6d3e753d446dbbaf722a012220..6d1b22259aafa487be0e1307d16673f09515ba51 100644 (file)
@@ -276,17 +276,17 @@ Subject: [PATCH 10/22] NET: MIPS: lantiq: update etop driver for devicetree
        struct ltq_etop_priv *priv = netdev_priv(dev);
 -      int i;
 +      int mii_mode = priv->mii_mode;
        struct ltq_etop_priv *priv = netdev_priv(dev);
 -      int i;
 +      int mii_mode = priv->mii_mode;
-+
-+      clk_enable(priv->clk_ppe);
  
 -      ltq_pmu_enable(PMU_PPE);
  
 -      ltq_pmu_enable(PMU_PPE);
++      clk_enable(priv->clk_ppe);
+-      switch (priv->pldata->mii_mode) {
 +      if (of_machine_is_compatible("lantiq,ar9")) {
 +              ltq_etop_gbit_init(dev);
 +              /* force the etops link to the gbit to MII */
 +              mii_mode = PHY_INTERFACE_MODE_MII;
 +      }
 +      if (of_machine_is_compatible("lantiq,ar9")) {
 +              ltq_etop_gbit_init(dev);
 +              /* force the etops link to the gbit to MII */
 +              mii_mode = PHY_INTERFACE_MODE_MII;
 +      }
--      switch (priv->pldata->mii_mode) {
++
 +      switch (mii_mode) {
        case PHY_INTERFACE_MODE_RMII:
                ltq_etop_w32_mask(ETOP_MII_MASK,
 +      switch (mii_mode) {
        case PHY_INTERFACE_MODE_RMII:
                ltq_etop_w32_mask(ETOP_MII_MASK,