generic: 5.10: refresh backport patches
authorChristian Marangi <ansuelsmth@gmail.com>
Sun, 16 Oct 2022 18:36:03 +0000 (20:36 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 16 Oct 2022 18:36:03 +0000 (20:36 +0200)
Refresh backport patches for kernel 5.10.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
target/linux/generic/backport-5.10/005-v5.17-02-Kbuild-move-to-std-gnu11.patch
target/linux/generic/backport-5.10/005-v5.17-03-Kbuild-use-std-gnu11-for-KBUILD_USERCFLAGS.patch
target/linux/generic/backport-5.10/011-kbuild-export-SUBARCH.patch

index dd8a1b445df4c4e4ca23e33d23805ba975548986..b01507e653d39f302fc105f8b0439107bef4b382 100644 (file)
@@ -39,13 +39,13 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
 +++ b/Makefile
 @@ -416,7 +416,8 @@ HOSTCXX    = g++
  endif
-
  export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
 -                            -O2 -fomit-frame-pointer -std=gnu89
 +                            -O2 -fomit-frame-pointer -std=gnu89 \
 +                            -Wdeclaration-after-statement
  export KBUILD_USERLDFLAGS :=
-
  KBUILD_HOSTCFLAGS   := $(KBUILD_USERCFLAGS) $(HOST_LFS_CFLAGS) $(HOSTCFLAGS)
 --- a/arch/arm64/kernel/vdso32/Makefile
 +++ b/arch/arm64/kernel/vdso32/Makefile
@@ -61,13 +61,13 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
 +++ b/scripts/mod/modpost.c
 @@ -844,8 +844,10 @@ static int match(const char *sym, const
  {
-       const char *p;
-       while (*pat) {
+       const char *p;
+       while (*pat) {
 +              const char *endp;
 +
-               p = *pat++;
+               p = *pat++;
 -              const char *endp = p + strlen(p) - 1;
 +              endp = p + strlen(p) - 1;
-
-               /* "*foo*" */
-               if (*p == '*' && *endp == '*') {
+               /* "*foo*" */
+               if (*p == '*' && *endp == '*') {
index 7938fe502696d047a985c1ce11262c4ec51366ca..c56cecfb719be5d008cf0fe1d00163306a10e034 100644 (file)
@@ -50,9 +50,9 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
 --- a/Makefile
 +++ b/Makefile
 @@ -498,7 +498,7 @@ KBUILD_CFLAGS   := -Wall -Wundef -Werror
-                  -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
-                  -Werror=implicit-function-declaration -Werror=implicit-int \
-                  -Werror=return-type -Wno-format-security \
+                  -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
+                  -Werror=implicit-function-declaration -Werror=implicit-int \
+                  -Werror=return-type -Wno-format-security \
 -                 -std=gnu89
 +                 -std=gnu11
  KBUILD_CPPFLAGS := -D__KERNEL__
index 34b5b653ae1897b74237afc58f8e5885c6eb4d36..e8d7c40d11b1d1df77e9b18d4225551135772011 100644 (file)
@@ -34,9 +34,10 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
 +++ b/Makefile
 @@ -416,7 +416,7 @@ HOSTCXX    = g++
  endif
-
  export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
 -                            -O2 -fomit-frame-pointer -std=gnu89 \
 +                            -O2 -fomit-frame-pointer -std=gnu11 \
-                             -Wdeclaration-after-statement
+                             -Wdeclaration-after-statement
  export KBUILD_USERLDFLAGS :=
index bb99e4ddbfa47189017ca16048fd7aa0fa09fbbc..f7e2d207cc3de433f5cc820fa60b560579109b81 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -507,7 +507,7 @@ KBUILD_LDFLAGS_MODULE :=
+@@ -508,7 +508,7 @@ KBUILD_LDFLAGS_MODULE :=
  KBUILD_LDFLAGS :=
  CLANG_FLAGS :=