kernel: bump 4.14 to 4.14.36
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Apr 2018 14:59:36 +0000 (16:59 +0200)
committerMathias Kresin <dev@kresin.me>
Thu, 26 Apr 2018 06:54:01 +0000 (08:54 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Fixes for CVEs:
CVE-2018-1108
CVE-2018-1092
CVE-2018-1094
CVE-2018-1095

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Tested-by: Stijn Segers <foss@volatilesystems.org>
include/kernel-version.mk
target/linux/cns3xxx/patches-4.14/075-spi_support.patch
target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
target/linux/mediatek/patches-4.14/0006-reset-mediatek-mt2701-reset-driver.patch
target/linux/mediatek/patches-4.14/0064-dts.patch

index 9191bddc7d00ab6ddc0fe6da1b95e2c0699ec6d4..8d0a62347cbfc460106d0a74168882ad7a4ef2ef 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .121
 LINUX_VERSION-4.9 = .96
-LINUX_VERSION-4.14 = .34
+LINUX_VERSION-4.14 = .36
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
 LINUX_KERNEL_HASH-4.9.96 = 826f596eb5197f8b17304649c2990dd7b766f5c79076cae79f4261c40cea877f
-LINUX_KERNEL_HASH-4.14.34 = 782b6c4c85275c382c820e1934d3e6003ef468f43cfc5e7c22bc07c331a12bb9
+LINUX_KERNEL_HASH-4.14.36 = cae24404d7b5812a331cbbc430b3ab75ca0f76eb16803528cbffbc42e768bc43
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 8a51eb396b478d0527bf7452f1a8fc3ac8d32576..e38dbdb75e10b21711ea5d8a53499616ac5bc44f 100644 (file)
@@ -39,7 +39,7 @@
  /**
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -1021,6 +1021,9 @@ static int spi_transfer_one_message(stru
+@@ -1027,6 +1027,9 @@ static int spi_transfer_one_message(stru
        list_for_each_entry(xfer, &msg->transfers, transfer_list) {
                trace_spi_transfer_start(msg, xfer);
  
index 180d1407d24f91d61f7537c78343c65b711671c5..2a09caf442548b4d4f5d6d9aeaffc0dc109451de 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
-@@ -1157,6 +1157,49 @@ static struct mtd_info * __init open_mtd
+@@ -1168,6 +1168,49 @@ static struct mtd_info * __init open_mtd
        return mtd;
  }
  
@@ -58,7 +58,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  static int __init ubi_init(void)
  {
        int err, i, k;
-@@ -1240,6 +1283,12 @@ static int __init ubi_init(void)
+@@ -1251,6 +1294,12 @@ static int __init ubi_init(void)
                }
        }
  
index 86cb454619da4d61a012a3bdcc980691bd0e3dc5..8a9da2c0881353f359f102dfd6deed647f66e565 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
-@@ -1170,6 +1170,9 @@ static void __init ubi_auto_attach(void)
+@@ -1181,6 +1181,9 @@ static void __init ubi_auto_attach(void)
        mtd = open_mtd_device("ubi");
        if (IS_ERR(mtd))
                mtd = open_mtd_device("data");
index a0fdc14f782c8c8fcfc9311dad9614f2d8994588..a443adfe64865889ee4269847f568a5f0146a08f 100644 (file)
@@ -16,7 +16,7 @@ Acked-by: Philipp Zabel <p.zabel@pengutronix.de>
 
 --- a/drivers/clk/mediatek/clk-mt2701.c
 +++ b/drivers/clk/mediatek/clk-mt2701.c
-@@ -771,6 +771,8 @@ static void mtk_infrasys_init_early(stru
+@@ -772,6 +772,8 @@ static void mtk_infrasys_init_early(stru
        if (r)
                pr_err("%s(): could not register clock provider: %d\n",
                        __func__, r);
index 47fc2b1b23d72fdc9d54782c6d2ae20a1ba1adad..cfae4fee64a4c8ff62205abb3384cbdda61aca3a 100644 (file)
@@ -11,7 +11,7 @@
        cpus {
                cpu@0 {
                        proc-supply = <&mt6323_vproc_reg>;
-@@ -84,6 +88,10 @@
+@@ -102,6 +106,10 @@
        memory@80000000 {
                reg = <0 0x80000000 0 0x40000000>;
        };
@@ -22,7 +22,7 @@
  };
  
  &cir {
-@@ -111,11 +119,24 @@
+@@ -129,11 +137,24 @@
                };
        };
  
@@ -49,7 +49,7 @@
                        compatible = "mediatek,mt7530";
                        #address-cells = <1>;
                        #size-cells = <0>;
-@@ -125,6 +146,8 @@
+@@ -143,6 +164,8 @@
                        core-supply = <&mt6323_vpa_reg>;
                        io-supply = <&mt6323_vemc3v3_reg>;
  
@@ -58,7 +58,7 @@
                        ports {
                                #address-cells = <1>;
                                #size-cells = <0>;
-@@ -133,29 +156,46 @@
+@@ -151,29 +174,46 @@
                                port@0 {
                                        reg = <0>;
                                        label = "wan";
                                        reg = <6>;
                                        label = "cpu";
                                        ethernet = <&gmac0>;
-@@ -168,8 +208,6 @@
+@@ -186,8 +226,6 @@
                                };
                        };
                };