kernel: bump 5.4 to 5.4.113
authorJohn Audia <graysky@archlinux.us>
Fri, 16 Apr 2021 13:46:53 +0000 (09:46 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Apr 2021 19:50:08 +0000 (21:50 +0200)
Ran update_kernel.sh in a fresh clone without any existing toolchains.  No
manual intervention needed.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/ramips/patches-5.4/991-at803x.patch

index 29be92246d401cd814b6062056d3fe99b5f70be9..6e8e9dc833bef25e1115f2fcbbb32dc9f974c51f 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .112
+LINUX_VERSION-5.4 = .113
 LINUX_VERSION-5.10 = .31
 
-LINUX_KERNEL_HASH-5.4.112 = b8361d461a4254c86d4c68aa4ceab1debaa3b2ccc6785542d026837a4fc20ca4
+LINUX_KERNEL_HASH-5.4.113 = 30cde92463c474b75f9eb197654570dd6dbb32ec20695544c5469f292662da47
 LINUX_KERNEL_HASH-5.10.31 = 54eef1a4d29a2582281375e028ac73c2c5d90dfa21500fa8c3b00e529a2b510d
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index af0132f8f7ed452cc205b121e9230581009175ee..95411211b2d3f5951431f0396871f5e182fc3667 100644 (file)
@@ -146,11 +146,11 @@ Signed-off-by: RenĂ© van Dorst <opensource@vdorst.com>
  static struct phy_driver at803x_driver[] = {
  {
        /* ATHEROS 8035 */
-@@ -491,6 +581,7 @@ static struct phy_driver at803x_driver[]
+@@ -461,6 +551,7 @@ static struct phy_driver at803x_driver[]
        .suspend                = at803x_suspend,
        .resume                 = at803x_resume,
        /* PHY_GBIT_FEATURES */
 +      .config_aneg            = at803x_config_aneg,
        .read_status            = at803x_read_status,
-       .aneg_done              = at803x_aneg_done,
-       .ack_interrupt          = &at803x_ack_interrupt,
+       .ack_interrupt          = at803x_ack_interrupt,
+       .config_intr            = at803x_config_intr,