ramips: add support for TP-Link RE205 v3
authorSteffen Loley <slo-src@web.de>
Sat, 10 Feb 2024 15:50:50 +0000 (16:50 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 23 Mar 2024 22:38:33 +0000 (23:38 +0100)
TP-Link RE205 v3 is a wireless range extender with Ethernet and 2.4G and 5G
WiFi with external antennas.
It's based on MediaTek MT7628AN+MT7610EN like the RE200 v3/v4 but with
external antennas.

Specifications
--------------

- MediaTek MT7628AN (580 Mhz)
- 64 MB of RAM
- 8 MB of FLASH
- 2T2R 2.4 GHz and 1T1R 5 GHz
- 1x 10/100 Mbps Ethernet
- 5x LED (GPIO-controlled), 2x button
- UART connection holes on PCB (57600 8n1)

There are 2.4G and 5G LEDs in blue which are controlled separately.

Installation
------------

Installation is identical to RE200 v3 devices as described at
https://openwrt.org/toh/tp-link/re200#installation

Web Interface
-------------

It is possible to upgrade to OpenWrt via the web interface. Simply flash
the -factory.bin from OEM. In contrast to a stock firmware, this will not
overwrite U-Boot.

Recovery
--------

U-Boot seems to be locked on newer versions, if not it can be accessed over
the UART as described in the link above.

Signed-off-by: Steffen Loley <slo-src@web.de>
target/linux/ramips/dts/mt7628an_tplink_re205-v3.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7628an_tplink_re205-v3.dts b/target/linux/ramips/dts/mt7628an_tplink_re205-v3.dts
new file mode 100644 (file)
index 0000000..f9390b1
--- /dev/null
@@ -0,0 +1,44 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_tplink_re200.dtsi"
+
+/ {
+       compatible = "tplink,re205-v3", "mediatek,mt7628an-soc";
+       model = "TP-Link RE205 v3";
+
+       /delete-node/ leds;
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       function = LED_FUNCTION_POWER;
+                       color = <LED_COLOR_ID_BLUE>;
+                       gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi5g {
+                       function = LED_FUNCTION_WLAN_5GHZ;
+                       color = <LED_COLOR_ID_BLUE>;
+                       gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               wifi2g {
+                       function = LED_FUNCTION_WLAN_2GHZ;
+                       color = <LED_COLOR_ID_BLUE>;
+                       gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               signal_blue {
+                       label = "blue:signal";
+                       gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
+               };
+
+               signal_red {
+                       label = "red:signal";
+                       gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
index 656820be145c369352b3e317edbe6c62243a0872..fc81266da946f2a6a5b9f3b77fef7d3e631ecbb5 100644 (file)
@@ -636,6 +636,16 @@ define Device/tplink_re200-v4
 endef
 TARGET_DEVICES += tplink_re200-v4
 
+define Device/tplink_re205-v3
+  $(Device/tplink-safeloader)
+  IMAGE_SIZE := 7808k
+  DEVICE_MODEL := RE205
+  DEVICE_VARIANT := v3
+  DEVICE_PACKAGES := kmod-mt76x0e
+  TPLINK_BOARD_ID := RE205-V3
+endef
+TARGET_DEVICES += tplink_re205-v3
+
 define Device/tplink_re220-v2
   $(Device/tplink-safeloader)
   IMAGE_SIZE := 7808k
index 5a0e0ab2148e488c17dbef75a92611f3c179ed37..da3ef154c082ea213949054c67a8d325cbcf95b5 100644 (file)
@@ -91,6 +91,9 @@ tplink,tl-mr3020-v3|\
 tplink,tl-wa801nd-v5)
        ucidef_set_led_netdev "lan" "lan" "green:lan" "eth0"
        ;;
+tplink,re205-v3)
+       ucidef_set_led_netdev "lan" "lan" "blue:signal" "eth0"
+       ;;
 tplink,re365-v1)
        ucidef_set_led_netdev "lan" "lan" "blue:lan" "eth0"
        ;;
index 63abb14d13916dd87d4473f8486e54a55aa449f5..fd8c086a85e2ef617718994a9e1c1e7468bf360a 100644 (file)
@@ -24,6 +24,7 @@ ramips_setup_interfaces()
        tplink,re200-v2|\
        tplink,re200-v3|\
        tplink,re200-v4|\
+       tplink,re205-v3|\
        tplink,re220-v2|\
        tplink,re305-v1|\
        tplink,re305-v3|\