brcm2708: convert to dt-based board-detection
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 17 Dec 2017 14:18:48 +0000 (15:18 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Mon, 25 Dec 2017 11:19:41 +0000 (12:19 +0100)
Use the values populated by the generic board detect function. The
first compatible from the device tree source file will be the board
name in userspace. The model property from the device tree source file
will be the model name.

Change the board name where used in the userspace and drop the target
specific board detect, to use the generic one.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/brcm2708/base-files/etc/board.d/02_network
target/linux/brcm2708/base-files/etc/diag.sh
target/linux/brcm2708/base-files/lib/brcm2708.sh [deleted file]
target/linux/brcm2708/base-files/lib/preinit/01_preinit_do_brcm2708.sh [deleted file]
target/linux/brcm2708/base-files/lib/preinit/05_set_preinit_iface_brcm2708
target/linux/brcm2708/image/Makefile

index 29bcf33e33fa51cba11e6c60316ff19f2cd1dcec..a9c947b65af7660c4ab8c728bc701f2492c528fe 100755 (executable)
@@ -11,13 +11,15 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
-rpi-2-b |\
-rpi-3-b |\
-rpi-b |\
-rpi-b-plus)
+raspberrypi,model-b |\
+raspberrypi,model-b-plus |\
+raspberrypi,model-b-rev2 |\
+raspberrypi,2-model-b |\
+raspberrypi,3-model-b)
        ucidef_set_interface_lan "eth0"
        ;;
-rpi-zero-w)
+
+raspberrypi,model-zero-w)
        ucidef_set_interface_lan "wlan0"
        ;;
 esac
index 6f5810ed5812edf024eb67a4ca3c2673ccf4a619..ce0f59151750d0a039520eee836ed49977a1d0f2 100644 (file)
@@ -7,14 +7,13 @@
 
 set_state() {
        case "$(board_name)" in
-       rpi-2-b |\
-       rpi-b-plus)
+       raspberrypi,2-model-b |\
+       raspberrypi,model-b-plus)
                status_led="led1"
                ;;
-       rpi-b |\
-       rpi-cm |\
-       rpi-zero |\
-       rpi-zero-w)
+       raspberrypi,model-b |\
+       raspberrypi,model-zero |\
+       raspberrypi,model-zero-w)
                status_led="led0"
                ;;
        esac
diff --git a/target/linux/brcm2708/base-files/lib/brcm2708.sh b/target/linux/brcm2708/base-files/lib/brcm2708.sh
deleted file mode 100644 (file)
index 76e678f..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2015-2016 OpenWrt.org
-# Copyright (C) 2017 LEDE project
-
-ifname=""
-
-brcm2708_detect() {
-       local board_name model
-
-       model=$(cat /proc/device-tree/model)
-       case "$model" in
-       "Raspberry Pi 2 Model B Rev"*)
-               board_name="rpi-2-b"
-               ;;
-       "Raspberry Pi 3 Model B Rev"*)
-               board_name="rpi-3-b"
-               ;;
-       "Raspberry Pi Compute Module Rev"*)
-               board_name="rpi-cm"
-               ;;
-       "Raspberry Pi Model B Plus Rev"* |\
-       "Raspberry Pi Model B+ Rev"*)
-               board_name="rpi-b-plus"
-               ;;
-       "Raspberry Pi Model B Rev"*)
-               board_name="rpi-b"
-               ;;
-       "Raspberry Pi Zero Rev"*)
-               board_name="rpi-zero"
-               ;;
-       "Raspberry Pi Zero W Rev"*)
-               board_name="rpi-zero-w"
-               ;;
-       *)
-               board_name="unknown"
-               ;;
-       esac
-
-       [ -e "/tmp/sysinfo" ] || mkdir -p "/tmp/sysinfo"
-
-       echo "$board_name" > /tmp/sysinfo/board_name
-       echo "$model" > /tmp/sysinfo/model
-}
diff --git a/target/linux/brcm2708/base-files/lib/preinit/01_preinit_do_brcm2708.sh b/target/linux/brcm2708/base-files/lib/preinit/01_preinit_do_brcm2708.sh
deleted file mode 100644 (file)
index 2943648..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2015 OpenWrt.org
-
-do_brcm2708() {
-       . /lib/brcm2708.sh
-
-       brcm2708_detect
-}
-
-boot_hook_add preinit_main do_brcm2708
index 95497cc5865ac0865cfbdbc4b51ce3bfe97b5817..76eb5905e8c86626ef8b82a64b910ac2c69b35f8 100644 (file)
@@ -6,10 +6,11 @@ set_preinit_iface() {
        . /lib/functions.sh
 
        case "$(board_name)" in
-       rpi-2-b |\
-       rpi-3-b |\
-       rpi-b |\
-       rpi-b-plus)
+       raspberrypi,2-model-b |\
+       raspberrypi,3-model-b |\
+       raspberrypi,model-b |\
+       raspberrypi,model-b-plus |\
+       raspberrypi,model-b-rev2)
                ifname=eth0
                ;;
        esac
index 41730b680305217051d4d00e622fcab7f2a784ea..9ea9a07a9dd27415a046a0cb2ca814aabf5ff343 100644 (file)
@@ -57,7 +57,7 @@ endef
 define Device/rpi
   DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
   DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
-  SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero-w
+  SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
 endef
 ifeq ($(SUBTARGET),bcm2708)
   TARGET_DEVICES += rpi
@@ -66,7 +66,7 @@ endif
 define Device/rpi-2
   DEVICE_TITLE := Raspberry Pi 2B/3B/3CM
   DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-cm3
-  SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-cm
+  SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,compute-module-3
 endef
 ifeq ($(SUBTARGET),bcm2709)
   TARGET_DEVICES += rpi-2
@@ -76,7 +76,7 @@ define Device/rpi-3
   KERNEL_IMG := kernel8.img
   DEVICE_TITLE := Raspberry Pi 3B (64 bit)
   DEVICE_DTS := broadcom/bcm2710-rpi-3-b
-  SUPPORTED_DEVICES := rpi-3-b
+  SUPPORTED_DEVICES := rpi-3-b raspberrypi,3-model-b
 endef
 ifeq ($(SUBTARGET),bcm2710)
   TARGET_DEVICES += rpi-3