kernel: fix kernel build for chipidea w/o usb-gadget
authorJohn Crispin <john@openwrt.org>
Tue, 3 Jun 2014 05:49:34 +0000 (05:49 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 3 Jun 2014 05:49:34 +0000 (05:49 +0000)
This resolves a module dependency kernel regression in r40905 with the
usb-chipidea module if usb-gadget was not selected.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 40992

package/kernel/linux/modules/usb.mk

index 10b89da715861f44a3503442514eadc12bfe997c..1fd4ddc4270d736cbad71bd28b97eef2a8a6febc 100644 (file)
@@ -1373,10 +1373,10 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.11.0)),1)
 else
   FILES:=\
        $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc.ko \
-       $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/gadget/udc-core.ko) \
+       $(if $(CONFIG_USB_GADGET),$(LINUX_DIR)/drivers/usb/gadget/udc-core.ko) \
        $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko) \
        $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko)
-  AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imxudc-core),1)
+  AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imx),1)
 endif
   $(call AddDepends/usb)
 endef