tools/libressl: disable assembly code for all hosts
authorMichael Pratt <mcpratt@pm.me>
Wed, 20 Jul 2022 23:17:22 +0000 (19:17 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 31 Jul 2022 16:46:23 +0000 (18:46 +0200)
This SSL library is for hosts only
and not shipped as a build product,
therefore its performance quality (speed) is not critical.

Assembly code is broken in LibreSSL for some x86_64 hosts (part of git history)
and for some RISC host archs like armv7l, aarch64, powerpc, ppc64, etc...
so let's just disable it for all hosts.

For example, this fixes an instance on ARM hosts
where the host Python 3 builds broken modules which link to LibreSSL,
even with patches that enable LibreSSL support
with the import error "unexpected reloc type 3".

Ref: a395563f6 ("build: fix libressl build on x32 (amd64ilp32) host ")
Suggested-by: Andre Heider <a.heider@gmail.com>
Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/libressl/Makefile

index aecc788972992c540189dee0f026eae7faff7aaa..bf2bd4e999f57d89a33ad1eead69eec567a5588f 100644 (file)
@@ -30,11 +30,8 @@ HOST_CFLAGS += $(HOST_FPIC)
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --disable-asm \
        --with-pic \
        --disable-tests
 
-ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
-HOST_CONFIGURE_ARGS += --disable-asm
-endif
-
 $(eval $(call HostBuild))