iproute2: update to 3.11
authorLuka Perkov <luka@openwrt.org>
Mon, 7 Oct 2013 08:26:41 +0000 (08:26 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 7 Oct 2013 08:26:41 +0000 (08:26 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38313

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/000-warnings.patch [deleted file]
package/network/utils/iproute2/patches/008-no_netem.patch
package/network/utils/iproute2/patches/110-extra-ccopts.patch
package/network/utils/iproute2/patches/200-add-tc_esfq.patch

index 1b42517bacd1075e688ee5fd0f2609c561a65427..dbacd275c6169659dfbe9abb9170d38415a9d1b4 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=3.10.0
+PKG_VERSION:=3.11.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
-PKG_MD5SUM:=45fb5427fc723a0001c72b92c931ba02
+PKG_MD5SUM:=d7ffb27bc9f0d80577b1f3fb9d1a7689
 PKG_BUILD_PARALLEL:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
diff --git a/package/network/utils/iproute2/patches/000-warnings.patch b/package/network/utils/iproute2/patches/000-warnings.patch
deleted file mode 100644 (file)
index 8f07c38..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -30,8 +30,7 @@ CC = gcc
- HOSTCC = gcc
- DEFINES += -D_GNU_SOURCE
- CCOPTS = -O2
--WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
--WFLAGS += -Wmissing-declarations -Wold-style-definition
-+WFLAGS := -Wall -Wstrict-prototypes
- CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
- YACCFLAGS = -d -t -v
index 78baeadbd153877fba5b2d100caf2532b0b0a09c..165ce0c9b9594f805372b13211bbfcc926db4cc5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -35,7 +35,7 @@ WFLAGS := -Wall -Wstrict-prototypes
+@@ -36,7 +36,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
  CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
  YACCFLAGS = -d -t -v
  
index 71ec957ad0c83895e7dad774716f55e4ab82fbb6..4a08757bd913cdc32cc232d0c1aea8ef34f5a247 100644 (file)
@@ -6,6 +6,6 @@
  DEFINES += -D_GNU_SOURCE
 -CCOPTS = -O2
 +CCOPTS = -O2 $(EXTRA_CCOPTS)
- WFLAGS := -Wall -Wstrict-prototypes
+ WFLAGS := -Wall -Wstrict-prototypes  -Wmissing-prototypes
+ WFLAGS += -Wmissing-declarations -Wold-style-definition
  
- CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
index df5dc017a24fb86cd2900cf74162abfc4bfbe939..f09b45004fe2095ded62f8079253673814bb22c2 100644 (file)
@@ -10,7 +10,7 @@
  TCMODULES += q_tbf.o
 --- a/include/linux/pkt_sched.h
 +++ b/include/linux/pkt_sched.h
-@@ -214,6 +214,33 @@ struct tc_sfq_xstats {
+@@ -222,6 +222,33 @@ struct tc_sfq_xstats {
        __s32           allot;
  };