base-files: reduce number of `mkdir` calls
authorPaul Spooren <mail@aparcar.org>
Sun, 12 Sep 2021 08:46:06 +0000 (22:46 -1000)
committerPaul Spooren <mail@aparcar.org>
Fri, 24 Sep 2021 07:40:52 +0000 (21:40 -1000)
The `mkdir` commands supports passing multiple arguments to batch create
multiple folders, instead of calling the tool every single time.

If the creation of one of the folders fails, all other folder are still
created and therefore doesn't change the error handling.

Also stop creating `/etc/` explicitly after subfolders of `/etc/` were
already created.

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/base-files/Makefile

index f87fd0fe6a1f02d19146fec0561bea4e6329e73b..af5c0e6b004704b4094264bd9228703bb1b8b29b 100644 (file)
@@ -161,24 +161,27 @@ define Package/base-files/install
                $(1)/etc/preinit \
                $(1)/etc/profile
 
-       mkdir -p $(1)/CONTROL
-       mkdir -p $(1)/dev
-       mkdir -p $(1)/etc/config
-       mkdir -p $(1)/etc/crontabs
-       mkdir -p $(1)/etc/rc.d
-       mkdir -p $(1)/overlay
-       mkdir -p $(1)/lib/firmware
+       mkdir -p \
+               $(1)/CONTROL \
+               $(1)/dev \
+               $(1)/etc/config \
+               $(1)/etc/crontabs \
+               $(1)/etc/rc.d \
+               $(1)/overlay \
+               $(1)/lib/firmware \
+               $(1)/mnt \
+               $(1)/proc \
+               $(1)/tmp \
+               $(1)/usr/lib \
+               $(1)/usr/bin \
+               $(1)/sys \
+               $(1)/www \
+               $(1)/root
+
+       $(LN) /proc/mounts $(1)/etc/mtab
        $(if $(LIB_SUFFIX),-$(LN) lib $(1)/lib$(LIB_SUFFIX))
-       mkdir -p $(1)/mnt
-       mkdir -p $(1)/proc
-       mkdir -p $(1)/tmp
-       mkdir -p $(1)/usr/lib
        $(if $(LIB_SUFFIX),-$(LN) lib $(1)/usr/lib$(LIB_SUFFIX))
-       mkdir -p $(1)/usr/bin
-       mkdir -p $(1)/sys
-       mkdir -p $(1)/www
-       mkdir -p $(1)/root
-       $(LN) /proc/mounts $(1)/etc/mtab
+
 ifneq ($(CONFIG_TARGET_ROOTFS_PERSIST_VAR),y)
        rm -f $(1)/var
        $(LN) tmp $(1)/var
@@ -186,7 +189,6 @@ else
        mkdir -p $(1)/var
        $(LN) /tmp/run $(1)/var/run
 endif
-       mkdir -p $(1)/etc
        $(LN) /tmp/resolv.conf /tmp/TZ /tmp/localtime $(1)/etc/
 
        chmod 0600 $(1)/etc/shadow