armvirt: 64: add missing kernel config symbols
authorJo-Philipp Wich <jo@mein.io>
Tue, 9 Jan 2018 23:39:14 +0000 (00:39 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 9 Jan 2018 23:44:08 +0000 (00:44 +0100)
Fixes: aa100b66f2 ("armvirt: bump to v4.14")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/armvirt/64/config-default

index c58863d..4e63668 100644 (file)
@@ -38,8 +38,11 @@ CONFIG_ARM64_HW_AFDBM=y
 CONFIG_ARM64_MODULE_CMODEL_LARGE=y
 CONFIG_ARM64_PAGE_SHIFT=12
 CONFIG_ARM64_PAN=y
+# CONFIG_ARM64_PMEM is not set
 # CONFIG_ARM64_PTDUMP is not set
+# CONFIG_ARM64_PTDUMP_DEBUGFS is not set
 # CONFIG_ARM64_RANDOMIZE_TEXT_OFFSET is not set
+# CONFIG_ARM64_SW_TTBR0_PAN is not set
 CONFIG_ARM64_UAO=y
 CONFIG_ARM64_VA_BITS=39
 CONFIG_ARM64_VA_BITS_39=y
@@ -71,15 +74,20 @@ CONFIG_CPU_IDLE=y
 CONFIG_CPU_IDLE_GOV_MENU=y
 CONFIG_CPU_PM=y
 CONFIG_CRYPTO_ABLK_HELPER=y
+CONFIG_CRYPTO_AES_ARM64_BS=y
 CONFIG_CRYPTO_AES_ARM64_CE=y
 CONFIG_CRYPTO_AES_ARM64_CE_BLK=y
 CONFIG_CRYPTO_AES_ARM64_CE_CCM=y
 CONFIG_CRYPTO_AES_ARM64_NEON_BLK=y
+CONFIG_CRYPTO_CHACHA20_NEON=y
 CONFIG_CRYPTO_CRC32_ARM64=y
+CONFIG_CRYPTO_CRC32_ARM64_CE=y
 CONFIG_CRYPTO_CRYPTD=y
+# CONFIG_CRYPTO_DEV_CAVIUM_ZIP is not set
 CONFIG_CRYPTO_GHASH_ARM64_CE=y
 CONFIG_CRYPTO_SHA1_ARM64_CE=y
 CONFIG_CRYPTO_SHA2_ARM64_CE=y
+CONFIG_CRYPTO_SHA512_ARM64=y
 # CONFIG_DEBUG_ALIGN_RODATA is not set
 CONFIG_DEBUG_BUGVERBOSE=y
 CONFIG_DEBUG_RODATA=y
@@ -126,6 +134,7 @@ CONFIG_MFD_SYSCON=y
 CONFIG_MFD_VEXPRESS_SYSREG=y
 CONFIG_MMC=y
 CONFIG_MMC_ARMMMCI=y
+# CONFIG_MMC_CAVIUM_THUNDERX is not set
 # CONFIG_MMC_TIFM_SD is not set
 CONFIG_MODULES_USE_ELF_RELA=y
 # CONFIG_MTD_PHYSMAP_OF is not set
@@ -133,11 +142,14 @@ CONFIG_NEED_SG_DMA_LENGTH=y
 CONFIG_NO_HZ=y
 CONFIG_NO_HZ_COMMON=y
 CONFIG_NO_HZ_IDLE=y
+CONFIG_NR_CPUS=64
 # CONFIG_NUMA is not set
+# CONFIG_PCIE_KIRIN is not set
 CONFIG_PCI_BUS_ADDR_T_64BIT=y
 # CONFIG_PCI_HISI is not set
 # CONFIG_PCI_HOST_THUNDER_ECAM is not set
 # CONFIG_PCI_HOST_THUNDER_PEM is not set
+# CONFIG_PCI_XGENE is not set
 CONFIG_PGTABLE_LEVELS=3
 CONFIG_PHYS_ADDR_T_64BIT=y
 # CONFIG_PHY_XGENE is not set
@@ -168,3 +180,4 @@ CONFIG_SYS_SUPPORTS_HUGETLBFS=y
 CONFIG_VEXPRESS_CONFIG=y
 CONFIG_VEXPRESS_SYSCFG=y
 CONFIG_VIDEOMODE_HELPERS=y
+CONFIG_VMAP_STACK=y