bcm53xx: add support for Asus RT-AC88U
authorArınç ÜNAL <arinc.unal@arinc9.com>
Fri, 12 Nov 2021 10:56:15 +0000 (18:56 +0800)
committerRafał Miłecki <rafal@milecki.pl>
Tue, 29 Mar 2022 14:10:07 +0000 (16:10 +0200)
Asus RT-AC88U is an AC3100 router featuring 9 Ethernet ports over the
integrated Broadcom and the external Realtek switch.

Hardware info:
* Processor: Broadcom BCM4709C0KFEBG dual-core @ 1.4 GHz
* Switch: BCM53012 in BCM4709C0KFEBG & external RTL8365MB
* DDR3 RAM: 512 MB
* Flash: 128 MB (ESMT F59L1G81LA-25T)
* 2.4GHz: BCM4366 4×4 2.4/5G single chip 802.11ac SoC
* 5GHz: BCM4366 4×4 2.4/5G single chip 802.11ac SoC
* Ports: 8 Ports, 1 WAN Ports

Flashing instructions:
* Boot to CFE Recovery Mode by holding the reset button while power-on.
* Connect to the router with an ethernet cable.
* Set IPv4 address of the computer to 192.168.1.2 subnet 255.255.255.0.
* Head to http://192.168.1.1.
* Reset NVRAM.
* Upload the OpenWrt image.

CFE bootloader may reject flashing the image due to image integrity check.
In that case, follow the instructions below.

* Rename the OpenWrt image as firmware.trx.
* Run a TFTP server and make it serve the firmware.trx file.
* Run the URL below on a browser or curl.
  http://192.168.1.1/do.htm?cmd=flash+-noheader+192.168.1.2:firmware.trx+flash0.trx

Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
[rmilecki: mark BROKEN until we sort out nvram & CFE recovery]
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm53xx/base-files/etc/board.d/02_network
target/linux/bcm53xx/image/Makefile

index 6d970e1d0e3acf61f106be9ce93a2d9b1dcc5dca..822320c0a6a7f510b57bfd4ee9043d1c1335e933 100644 (file)
@@ -13,6 +13,9 @@ bcm53xx_setup_interfaces()
        asus,rt-ac87u)
                ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
                ;;
+       asus,rt-ac88u)
+               ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 extsw" "wan"
+               ;;
        linksys,panamera)
                ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8 extsw" "wan"
                ;;
index aadac9c3d4e9ab2a6ca2cb4ebcbda08c288c3a6a..3df24013ce6028f2a05cf742a8105cc95e01a1c9 100644 (file)
@@ -167,6 +167,15 @@ define Device/asus_rt-ac87u
 endef
 TARGET_DEVICES += asus_rt-ac87u
 
+define Device/asus_rt-ac88u
+  $(call Device/asus)
+  DEVICE_MODEL := RT-AC88U
+  DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+  ASUS_PRODUCTID := RT-AC88U
+  BROKEN := y
+endef
+TARGET_DEVICES += asus_rt-ac88u
+
 define Device/asus_rt-n18u
   $(call Device/asus)
   DEVICE_MODEL := RT-N18U