Revert "wpa_supplicant: log to syslog instead of stdout"
authorJo-Philipp Wich <jo@mein.io>
Fri, 27 Oct 2017 09:37:11 +0000 (11:37 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 27 Oct 2017 09:43:59 +0000 (11:43 +0200)
This reverts commit e7373e489d8a215402d6b0c408a26188342c7c17.

Support of "-s" depends on the CONFIG_DEBUG_SYSLOG compile time flag which
is not enabled for all build variants.

Revert the change for now until we can properly examine the size impact of
CONFIG_DEBUG_SYSLOG.

Fixes FS#1117.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index 5a353e67ed1a26a4106be234d5d5959b9358108b..f1d057d44ea8f6bf7e1079c53ff8d37d5ab19d4f 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 16925d58a234bb04b5c8e22c72b762c0afd7fe9d..144e49b1204b1bc1f3a92b82e28249c90e9569aa 100644 (file)
@@ -773,7 +773,7 @@ wpa_supplicant_run() {
 
        _wpa_supplicant_common "$ifname"
 
-       /usr/sbin/wpa_supplicant -B -s \
+       /usr/sbin/wpa_supplicant -B \
                ${network_bridge:+-b $network_bridge} \
                -P "/var/run/wpa_supplicant-${ifname}.pid" \
                -D ${_w_driver:-wext} \