kernel: bump 4.9 to 4.9.125
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 6 Sep 2018 12:23:27 +0000 (14:23 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 7 Sep 2018 15:21:24 +0000 (17:21 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm47xx/patches-4.9/830-huawei_e970_support.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 916120c046f5a582b563ddabc3653006d806c223..c707950ebdad780dd845664799d9f1f8c2be3b77 100644 (file)
@@ -2,13 +2,13 @@
 
 LINUX_RELEASE?=1
 
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .124
 LINUX_VERSION-4.14 = .67
 LINUX_VERSION-3.18 = .121
 LINUX_VERSION-4.14 = .67
 LINUX_VERSION-3.18 = .121
+LINUX_VERSION-4.9 = .125
 
 
-LINUX_KERNEL_HASH-4.9.124 = 5ca6b0d48c8dd1265005169f1b97149a4e893668c0d8aa566a73c7663c8e4311
 LINUX_KERNEL_HASH-4.14.67 = 3f4b056dc27233a78f7a4a35ed6fdcfd0a9680ec40b611a898bb6c8b905070ba
 LINUX_KERNEL_HASH-3.18.121 = 7a8a996433e4af1abd2903f91c390295745d90dd178607b3af82f2df5f95c9b0
 LINUX_KERNEL_HASH-4.14.67 = 3f4b056dc27233a78f7a4a35ed6fdcfd0a9680ec40b611a898bb6c8b905070ba
 LINUX_KERNEL_HASH-3.18.121 = 7a8a996433e4af1abd2903f91c390295745d90dd178607b3af82f2df5f95c9b0
+LINUX_KERNEL_HASH-4.9.125 = a764deef61bebfac1d07b2ed6890f93a12a9ab6d3fc3c53e3d850ed4681111cb
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 5d40fe6541616dbe23927fa623326d5a8a9728e3..b6150ed8fd9763ca3534e32173407afa5d6853c9 100644 (file)
@@ -8,7 +8,7 @@
  #include <asm/bootinfo.h>
  #include <asm/idle.h>
  #include <asm/prom.h>
  #include <asm/bootinfo.h>
  #include <asm/idle.h>
  #include <asm/prom.h>
-@@ -231,6 +232,33 @@ static struct fixed_phy_status bcm47xx_f
+@@ -225,6 +226,33 @@ static struct fixed_phy_status bcm47xx_f
        .duplex = DUPLEX_FULL,
  };
  
        .duplex = DUPLEX_FULL,
  };
  
@@ -42,7 +42,7 @@
  static int __init bcm47xx_register_bus_complete(void)
  {
        switch (bcm47xx_bus_type) {
  static int __init bcm47xx_register_bus_complete(void)
  {
        switch (bcm47xx_bus_type) {
-@@ -250,6 +278,7 @@ static int __init bcm47xx_register_bus_c
+@@ -244,6 +272,7 @@ static int __init bcm47xx_register_bus_c
        bcm47xx_workarounds();
  
        fixed_phy_add(PHY_POLL, 0, &bcm47xx_fixed_phy_status, -1);
        bcm47xx_workarounds();
  
        fixed_phy_add(PHY_POLL, 0, &bcm47xx_fixed_phy_status, -1);
index 127707827e21c9a7fd5d5761a1c7b8a32d2f071e..3268b3407ac0c6a8e7e197daccd594ef43007a8c 100644 (file)
@@ -302,7 +302,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (alx->flags & ALX_FLAG_USING_MSIX) {
 --- a/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
 +++ b/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
        if (alx->flags & ALX_FLAG_USING_MSIX) {
 --- a/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
 +++ b/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
-@@ -1885,7 +1885,7 @@ static int atl1c_clean(struct napi_struc
+@@ -1886,7 +1886,7 @@ static int atl1c_clean(struct napi_struc
  
        if (work_done < budget) {
  quit_polling:
  
        if (work_done < budget) {
  quit_polling:
index 7afef36e4be8b07760a56c2932acee615200441e..3c278099d3fc781d83dc4fc6295462ef45ba2910 100644 (file)
@@ -1658,7 +1658,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                        return IRQ_HANDLED;
                }
        }
                        return IRQ_HANDLED;
                }
        }
-@@ -923,12 +932,32 @@ int usb_otg_start(struct platform_device
+@@ -925,12 +934,32 @@ int usb_otg_start(struct platform_device
        temp &= ~(PORTSC_PHY_TYPE_SEL | PORTSC_PTW);
        switch (pdata->phy_mode) {
        case FSL_USB2_PHY_ULPI:
        temp &= ~(PORTSC_PHY_TYPE_SEL | PORTSC_PTW);
        switch (pdata->phy_mode) {
        case FSL_USB2_PHY_ULPI: