openvpn: make size optimization configurable
authorFelix Fietkau <nbd@openwrt.org>
Tue, 11 Mar 2014 12:07:17 +0000 (12:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 11 Mar 2014 12:07:17 +0000 (12:07 +0000)
Signed-off-by: Christoph Kottke <christoph.kottke@gmx.de>
SVN-Revision: 39872

package/network/services/openvpn/Config-nossl.in
package/network/services/openvpn/Config-openssl.in
package/network/services/openvpn/Config-polarssl.in
package/network/services/openvpn/Makefile

index 98cba25cc08b172e87cf72653a16b4aed2018c20..3eaa2288824bc599d4f3c8aae12a340e02f0fd53 100644 (file)
@@ -44,4 +44,11 @@ config OPENVPN_nossl_ENABLE_IPROUTE2
        bool "Enable support for iproute2"
        default n
 
+config OPENVPN_nossl_ENABLE_SMALL
+       bool "Enable size optimization"
+       default y
+       help
+         enable smaller executable size (disable OCC, usage
+         message, and verb 4 parm list)
+
 endif
index 66861219dfde64acb6e88cba1822bd6dd461d1eb..ac4c774b039cb64d06ce3f25eb60373e291eb5a9 100644 (file)
@@ -56,4 +56,11 @@ config OPENVPN_openssl_ENABLE_IPROUTE2
        bool "Enable support for iproute2"
        default n
 
+config OPENVPN_openssl_ENABLE_SMALL
+       bool "Enable size optimization"
+       default y
+       help
+         enable smaller executable size (disable OCC, usage
+         message, and verb 4 parm list)
+
 endif
index 64c44972412c5ed5533b6a02d2f11543a0029966..26692ce04de775e967ccde33af6a46d8afa43a54 100644 (file)
@@ -56,4 +56,11 @@ config OPENVPN_polarssl_ENABLE_IPROUTE2
        bool "Enable support for iproute2"
        default n
 
+config OPENVPN_polarssl_ENABLE_SMALL
+       bool "Enable size optimization"
+       default y
+       help
+         enable smaller executable size (disable OCC, usage
+         message, and verb 4 parm list)
+
 endif
index f6c4381b09854b233ebdde6c9f83dc12d14e1777..a05248c132f819bbb35429b5c94498eff4d3d32b 100644 (file)
@@ -66,7 +66,7 @@ CONFIGURE_VARS += \
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --enable-small \
+               $(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_SMALL),--enable-small) \
                --disable-selinux \
                --disable-systemd \
                --disable-plugins \