kernel: bump 5.4 to 5.4.66
authorJohn Audia <graysky@archlinux.us>
Thu, 17 Sep 2020 13:51:25 +0000 (09:51 -0400)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 19 Sep 2020 10:41:29 +0000 (12:41 +0200)
All modifications made by update_kernel.sh/no manual intervention needed

Run-tested: ipq806x (R7800), ath79 (Archer C7v5), x86/64

No dmesg regressions, everything appears functional

Signed-off-by: John Audia <graysky@archlinux.us>
[add run test from PR]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
21 files changed:
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0037-Add-dwc_otg-driver.patch
target/linux/bcm27xx/patches-5.4/950-0283-hid-usb-Add-device-quirks-for-Freeway-Airmouse-T3-an.patch
target/linux/ipq40xx/patches-5.4/100-GPIO-add-named-gpio-exports.patch
target/linux/ipq40xx/patches-5.4/400-mmc-sdhci-sdhci-msm-use-sdhci_set_clock-instead-of-s.patch
target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch
target/linux/ipq806x/patches-5.4/851-add-gsbi1-dts.patch
target/linux/ipq806x/patches-5.4/997-device_tree_cmdline.patch
target/linux/layerscape/patches-5.4/811-kvm-0002-arm-arm64-KVM-allow-specifying-s2-prot-bits-when-map.patch
target/linux/layerscape/patches-5.4/811-kvm-0003-arm-arm64-KVM-drop-qman-mmio-cacheable-mapping-hack.patch
target/linux/layerscape/patches-5.4/816-sdhc-0001-mmc-sdhci-of-esdhc-poll-ESDHC_FLUSH_ASYNC_FIFO-bit-u.patch
target/linux/layerscape/patches-5.4/816-sdhc-0002-LF-605-mmc-sdhci-of-esdhc-convert-to-use-esdhc_tunin.patch
target/linux/layerscape/patches-5.4/816-sdhc-0003-LF-605-mmc-sdhci-of-esdhc-update-tuning-erratum-A-00.patch
target/linux/mediatek/patches-5.4/0600-net-phylink-propagate-resolved-link-config-via-mac_l.patch
target/linux/ramips/patches-5.4/401-net-ethernet-mediatek-support-net-labels.patch
target/linux/rtl838x/patches-5.4/300-mips-add-rtl838x-platform.patch
target/linux/rtl838x/patches-5.4/301-gpio-add-rtl838x-driver.patch
target/linux/rtl838x/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
target/linux/rtl838x/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch
target/linux/rtl838x/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch
target/linux/rtl838x/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch

index 716e09f8c152a7f1e291bc2b5c250ad4bc020335..5b9a6ad6d8ec5757deab25e4feb81a079dbe9139 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.19 = .138
-LINUX_VERSION-5.4 = .65
+LINUX_VERSION-5.4 = .66
 
 LINUX_KERNEL_HASH-4.19.138 = d15c27d05f6c527269b75b30cc72972748e55720e7e00ad8abbaa4fe3b1d5e02
-LINUX_KERNEL_HASH-5.4.65 = f514834417d09de1667836e443e085bf37952603f23572b69ef0fcfda16cac69
+LINUX_KERNEL_HASH-5.4.66 = ff1930376774f4c1fc884d82184b5ebea6628f0a37ed9be781c0b119c4cfdab2
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index fe4d1d9a007c68255d09d374023d9d00030064dd..5b7f773b0b4db3c552e67caf60b1507ae24e7e20 100644 (file)
@@ -1051,7 +1051,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
                                USB_PORT_FEAT_C_OVER_CURRENT);
 --- a/drivers/usb/core/message.c
 +++ b/drivers/usb/core/message.c
-@@ -2000,6 +2000,85 @@ free_interfaces:
+@@ -1993,6 +1993,85 @@ free_interfaces:
        if (cp->string == NULL &&
                        !(dev->quirks & USB_QUIRK_CONFIG_INTF_STRINGS))
                cp->string = usb_cache_string(dev, cp->desc.iConfiguration);
index 799666ec9aa2b48cf9668b4e58a09c58eb597932..d2e7c9944f45f23c15912799be6d06a8a77d323a 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
  #define USB_VENDOR_ID_BELKIN          0x050d
  #define USB_DEVICE_ID_FLIP_KVM                0x3201
  
-@@ -1241,6 +1244,9 @@
+@@ -1244,6 +1247,9 @@
  #define USB_VENDOR_ID_XAT     0x2505
  #define USB_DEVICE_ID_XAT_CSR 0x0220
  
@@ -53,7 +53,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_MULTI_TOUCH), HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE), HID_QUIRK_ALWAYS_POLL },
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE2), HID_QUIRK_ALWAYS_POLL },
-@@ -182,6 +183,7 @@ static const struct hid_device_id hid_qu
+@@ -184,6 +185,7 @@ static const struct hid_device_id hid_qu
        { HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP_LTD2, USB_DEVICE_ID_SMARTJOY_DUAL_PLUS), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP, USB_DEVICE_ID_QUAD_USB_JOYPAD), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_XIN_MO, USB_DEVICE_ID_XIN_MO_DUAL_ARCADE), HID_QUIRK_MULTI_INPUT },
index 61ed9ea784e79f53104702d288fa915c8cee2421..d4ea379159260064a5898a3c2f2765154baf7b5d 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/gpio/gpiolib-of.c
 +++ b/drivers/gpio/gpiolib-of.c
-@@ -23,6 +23,8 @@
+@@ -19,6 +19,8 @@
  #include <linux/pinctrl/pinctrl.h>
  #include <linux/slab.h>
  #include <linux/gpio/machine.h>
@@ -21,9 +21,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +#include <linux/platform_device.h>
  
  #include "gpiolib.h"
-@@ -513,3 +515,68 @@ void of_gpiochip_remove(struct gpio_chip
-       gpiochip_remove_pin_ranges(chip);
+ #include "gpiolib-of.h"
+@@ -915,3 +917,68 @@ void of_gpiochip_remove(struct gpio_chip
+ {
        of_node_put(chip->of_node);
  }
 +
@@ -93,7 +93,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +module_platform_driver(gpio_export_driver);
 --- a/drivers/gpio/gpiolib-sysfs.c
 +++ b/drivers/gpio/gpiolib-sysfs.c
-@@ -553,7 +553,7 @@ static struct class gpio_class = {
+@@ -563,7 +563,7 @@ static struct class gpio_class = {
   *
   * Returns zero on success, else an error.
   */
@@ -102,7 +102,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  {
        struct gpio_chip        *chip;
        struct gpio_device      *gdev;
-@@ -615,6 +615,8 @@ int gpiod_export(struct gpio_desc *desc,
+@@ -625,6 +625,8 @@ int gpiod_export(struct gpio_desc *desc,
        offset = gpio_chip_hwgpio(desc);
        if (chip->names && chip->names[offset])
                ioname = chip->names[offset];
@@ -111,7 +111,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
        dev = device_create_with_groups(&gpio_class, &gdev->dev,
                                        MKDEV(0, 0), data, gpio_groups,
-@@ -636,6 +638,12 @@ err_unlock:
+@@ -646,6 +648,12 @@ err_unlock:
        gpiod_dbg(desc, "%s: status %d\n", __func__, status);
        return status;
  }
@@ -141,7 +141,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  {
 --- a/include/linux/gpio/consumer.h
 +++ b/include/linux/gpio/consumer.h
-@@ -451,6 +451,7 @@ struct gpio_desc *devm_fwnode_get_gpiod_
+@@ -668,6 +668,7 @@ static inline void devm_acpi_dev_remove_
  
  #if IS_ENABLED(CONFIG_GPIOLIB) && IS_ENABLED(CONFIG_GPIO_SYSFS)
  
@@ -149,7 +149,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  int gpiod_export(struct gpio_desc *desc, bool direction_may_change);
  int gpiod_export_link(struct device *dev, const char *name,
                      struct gpio_desc *desc);
-@@ -458,6 +459,13 @@ void gpiod_unexport(struct gpio_desc *de
+@@ -675,6 +676,13 @@ void gpiod_unexport(struct gpio_desc *de
  
  #else  /* CONFIG_GPIOLIB && CONFIG_GPIO_SYSFS */
  
index cf5c44e68766cd4ea6d27c5b587e7bffebd7f2de..e56ab6d0f1c2380f8f8ec63382de32d0a03370e0 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
 
 --- a/drivers/mmc/host/sdhci-msm.c
 +++ b/drivers/mmc/host/sdhci-msm.c
-@@ -1730,7 +1730,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
+@@ -1746,7 +1746,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
  
  static const struct sdhci_ops sdhci_msm_ops = {
        .reset = sdhci_reset,
index e2dc45a39fac0bce7933618e8d1ec009928cc916..2b5220d3ed7cc2a9e09081a876931f077d3b351c 100644 (file)
@@ -8,10 +8,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
  arch/arm/boot/dts/Makefile | 23 +++++++++++++++++++++++
  1 file changed, 23 insertions(+)
 
-Index: linux-5.4.63/arch/arm/boot/dts/Makefile
-===================================================================
---- linux-5.4.63.orig/arch/arm/boot/dts/Makefile
-+++ linux-5.4.63/arch/arm/boot/dts/Makefile
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
 @@ -837,11 +837,52 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
index 2e1cb70e110fc781e70ed3fa7bbd516446f1750c..f75f9949046ca9a5eb41ddf9720345ff93d94408 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-5.4.65/arch/arm/boot/dts/qcom-ipq8064.dtsi
-===================================================================
---- linux-5.4.65.orig/arch/arm/boot/dts/qcom-ipq8064.dtsi
-+++ linux-5.4.65/arch/arm/boot/dts/qcom-ipq8064.dtsi
+--- a/arch/arm/boot/dts/qcom-ipq8064.dtsi
++++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi
 @@ -865,6 +865,41 @@
                        reg = <0x12100000 0x10000>;
                };
index 92f82b37889b6ddd57189261a1ab45e976cf14d2..3cc032fdd24bdb1758a821314077e4385f127712 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-5.4.65/drivers/of/fdt.c
-===================================================================
---- linux-5.4.65.orig/drivers/of/fdt.c
-+++ linux-5.4.65/drivers/of/fdt.c
+--- a/drivers/of/fdt.c
++++ b/drivers/of/fdt.c
 @@ -1059,6 +1059,9 @@ int __init early_init_dt_scan_chosen(uns
        p = of_get_flat_dt_prop(node, "bootargs", &l);
        if (p != NULL && l > 0)
index 309782b4602dbc148331f7a445bd36bd8958ca7e..bdc8725399a8bc3e10e5106f95eed4118562b2b7 100644 (file)
@@ -64,7 +64,7 @@ Signed-off-by: Laurentiu Tudor <laurentiu.tudor@nxp.com>
  
                if (writable)
                        pte = kvm_s2pte_mkwrite(pte);
-@@ -2356,7 +2358,7 @@ int kvm_arch_prepare_memory_region(struc
+@@ -2361,7 +2363,7 @@ int kvm_arch_prepare_memory_region(struc
  
                        ret = kvm_phys_addr_ioremap(kvm, gpa, pa,
                                                    vm_end - vm_start,
index 47ec98ec24a5435f476c482083eb7b75fb8101b0..1b36b61e6200d33e77a22ac873c2cfb8f6adf5e2 100644 (file)
@@ -105,7 +105,7 @@ Signed-off-by: Diana Craciun <diana.craciun@nxp.com>
        if (kvm_is_device_pfn(pfn)) {
                mem_type = PAGE_S2_DEVICE;
                flags |= KVM_S2PTE_FLAG_IS_IOMAP;
-@@ -2346,6 +2390,9 @@ int kvm_arch_prepare_memory_region(struc
+@@ -2351,6 +2395,9 @@ int kvm_arch_prepare_memory_region(struc
                        gpa_t gpa = mem->guest_phys_addr +
                                    (vm_start - mem->userspace_addr);
                        phys_addr_t pa;
@@ -115,7 +115,7 @@ Signed-off-by: Diana Craciun <diana.craciun@nxp.com>
  
                        pa = (phys_addr_t)vma->vm_pgoff << PAGE_SHIFT;
                        pa += vm_start - vma->vm_start;
-@@ -2356,9 +2403,13 @@ int kvm_arch_prepare_memory_region(struc
+@@ -2361,9 +2408,13 @@ int kvm_arch_prepare_memory_region(struc
                                goto out;
                        }
  
index 492ae99d026ca62e341ddb1fa1296ca3592abfc0..085de51c14065773f5670fd9565902ccb34c5533 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/drivers/mmc/host/sdhci-of-esdhc.c
 +++ b/drivers/mmc/host/sdhci-of-esdhc.c
-@@ -591,6 +591,32 @@ static void esdhc_clock_enable(struct sd
+@@ -592,6 +592,32 @@ static void esdhc_clock_enable(struct sd
        }
  }
  
@@ -47,7 +47,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static void esdhc_of_set_clock(struct sdhci_host *host, unsigned int clock)
  {
        struct sdhci_pltfm_host *pltfm_host = sdhci_priv(host);
-@@ -683,9 +709,7 @@ static void esdhc_of_set_clock(struct sd
+@@ -684,9 +710,7 @@ static void esdhc_of_set_clock(struct sd
                sdhci_writel(host, temp | ESDHC_HS400_WNDW_ADJUST, ESDHC_TBCTL);
  
                esdhc_clock_enable(host, false);
@@ -58,7 +58,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        }
  
        /* Wait max 20 ms */
-@@ -887,10 +911,7 @@ static void esdhc_tuning_block_enable(st
+@@ -888,10 +912,7 @@ static void esdhc_tuning_block_enable(st
        u32 val;
  
        esdhc_clock_enable(host, false);
index a80d5c91a4151bdd0caf4edfbbef53948fd4b193..df19568863c4189a1ac9b814851e527fdb1cd0ae 100644 (file)
@@ -15,7 +15,7 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
 
 --- a/drivers/mmc/host/sdhci-of-esdhc.c
 +++ b/drivers/mmc/host/sdhci-of-esdhc.c
-@@ -923,20 +923,11 @@ static void esdhc_tuning_block_enable(st
+@@ -924,20 +924,11 @@ static void esdhc_tuning_block_enable(st
        esdhc_clock_enable(host, true);
  }
  
@@ -37,7 +37,7 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
        /* Write TBCTL[11:8]=4'h8 */
        val = sdhci_readl(host, ESDHC_TBCTL);
        val &= ~(0xf << 8);
-@@ -955,6 +946,25 @@ static void esdhc_prepare_sw_tuning(stru
+@@ -956,6 +947,25 @@ static void esdhc_prepare_sw_tuning(stru
        val = sdhci_readl(host, ESDHC_TBSTAT);
        val = sdhci_readl(host, ESDHC_TBSTAT);
  
@@ -63,7 +63,7 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
        /* Reset data lines by setting ESDHCCTL[RSTD] */
        sdhci_reset(host, SDHCI_RESET_DATA);
        /* Write 32'hFFFF_FFFF to IRQSTAT register */
-@@ -965,10 +975,8 @@ static void esdhc_prepare_sw_tuning(stru
+@@ -966,10 +976,8 @@ static void esdhc_prepare_sw_tuning(stru
         * then program TBPTR[TB_WNDW_END_PTR] = 4 * div_ratio
         * and program TBPTR[TB_WNDW_START_PTR] = 8 * div_ratio.
         */
index fcdeb15d8f8ed4981570280eb9253465d3a6b2eb..1d2e9386c97600f24e5e01a0079aaa663d96fc42 100644 (file)
@@ -20,7 +20,7 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
 
 --- a/drivers/mmc/host/sdhci-of-esdhc.c
 +++ b/drivers/mmc/host/sdhci-of-esdhc.c
-@@ -889,20 +889,20 @@ static int esdhc_signal_voltage_switch(s
+@@ -890,20 +890,20 @@ static int esdhc_signal_voltage_switch(s
  }
  
  static struct soc_device_attribute soc_tuning_erratum_type1[] = {
@@ -51,7 +51,7 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
        { },
  };
  
-@@ -970,13 +970,13 @@ static void esdhc_prepare_sw_tuning(stru
+@@ -971,13 +971,13 @@ static void esdhc_prepare_sw_tuning(stru
        /* Write 32'hFFFF_FFFF to IRQSTAT register */
        sdhci_writel(host, 0xFFFFFFFF, SDHCI_INT_STATUS);
  
@@ -68,7 +68,7 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
                *window_start = 8 * esdhc->div_ratio;
                *window_end = 4 * esdhc->div_ratio;
        } else {
-@@ -1049,6 +1049,19 @@ static int esdhc_execute_tuning(struct m
+@@ -1050,6 +1050,19 @@ static int esdhc_execute_tuning(struct m
                if (ret)
                        break;
  
index a9b2b603bba7e944bd14b37d0d5b67cbd3a736fc..0eac2ed66ef5d96aebfbb3e81af1c92f5f09a4a2 100644 (file)
@@ -111,7 +111,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        struct mvpp2_port *port = netdev_priv(dev);
 --- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
 +++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-@@ -445,9 +445,10 @@ static void mtk_mac_link_down(struct phy
+@@ -446,9 +446,10 @@ static void mtk_mac_link_down(struct phy
        mtk_w32(mac->hw, mcr, MTK_MAC_MCR(mac->id));
  }
  
index 00e48fe662a0390b61a1e1b40abf1251b16f7877..39989ecca18ab78f0f18ef11a9cc5e0f7cf6ca4d 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: RenĂ© van Dorst <opensource@vdorst.com>
 
 --- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
 +++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-@@ -2863,6 +2863,7 @@ static const struct net_device_ops mtk_n
+@@ -2887,6 +2887,7 @@ static const struct net_device_ops mtk_n
  
  static int mtk_add_mac(struct mtk_eth *eth, struct device_node *np)
  {
@@ -22,7 +22,7 @@ Signed-off-by: RenĂ© van Dorst <opensource@vdorst.com>
        const __be32 *_id = of_get_property(np, "reg", NULL);
        struct phylink *phylink;
        int phy_mode, id, err;
-@@ -2955,6 +2956,9 @@ static int mtk_add_mac(struct mtk_eth *e
+@@ -2979,6 +2980,9 @@ static int mtk_add_mac(struct mtk_eth *e
  
        eth->netdev[id]->max_mtu = MTK_MAX_RX_LENGTH - MTK_RX_ETH_HLEN;
  
index 34fb959a508d59de58335577dd98c02dba36510b..ec114a04c9a02646743e450c8c4449743387082c 100644 (file)
@@ -10,7 +10,7 @@
  platforms += sgi-ip27
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -629,6 +629,29 @@ config RALINK
+@@ -630,6 +630,29 @@ config RALINK
        select ARCH_HAS_RESET_CONTROLLER
        select RESET_CONTROLLER
  
index 5eb8521ccb41921ce6244cedf7d0f6f91fc46812..f911e5158b7872e6ce986d515ee78c4ca6da5795 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -441,6 +441,12 @@
+@@ -441,6 +441,12 @@ config GPIO_REG
          A 32-bit single register GPIO fixed in/out implementation.  This
          can be used to represent any register as a set of GPIO signals.
  
@@ -15,7 +15,7 @@
        depends on MFD_SYSCON
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -117,6 +117,7 @@
+@@ -117,6 +117,7 @@ obj-$(CONFIG_GPIO_RC5T583)         += gpio-rc5t
  obj-$(CONFIG_GPIO_RCAR)                       += gpio-rcar.o
  obj-$(CONFIG_GPIO_RDC321X)            += gpio-rdc321x.o
  obj-$(CONFIG_GPIO_REG)                        += gpio-reg.o
index 0082176d8304d96a875593380c8d2d29b3421d6a..7dd12b79172f15f4aa739061b7d488f11564e203 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/dsa/Kconfig
 +++ b/drivers/net/dsa/Kconfig
-@@ -74,6 +74,13 @@ config NET_DSA_REALTEK_SMI
+@@ -75,6 +75,13 @@ config NET_DSA_REALTEK_SMI
          This enables support for the Realtek SMI-based switch
          chips, currently only RTL8366RB.
  
index 5329dcad5994b3549b7867c36f53ec1015ce7de5..929f2b94445183d973247bf9882a2320a596030a 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-5.4.24/include/linux/platform_data/dsa.h
-===================================================================
---- linux-5.4.24.orig/include/linux/platform_data/dsa.h
-+++ linux-5.4.24/include/linux/platform_data/dsa.h
+--- a/include/linux/platform_data/dsa.h
++++ b/include/linux/platform_data/dsa.h
 @@ -6,7 +6,7 @@ struct device;
  struct net_device;
  
index db8b0403f7d509a862e530855361cd5c6335d400..c61b5f6fffca676fb8a407c46b463592fbcf97e2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -628,6 +628,10 @@
+@@ -650,6 +650,10 @@ struct phy_driver {
                            struct ethtool_tunable *tuna,
                            const void *data);
        int (*set_loopback)(struct phy_device *dev, bool enable);
index 5262be53c6b26e35991ddba3f74669739079a2b6..7743147ea30233fe92a28065ad3b6a7eefa01bcc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -1244,6 +1244,11 @@
+@@ -1242,6 +1242,11 @@ int phylink_ethtool_ksettings_set(struct
  
        /* If we have a PHY, configure the phy */
        if (pl->phydev) {
@@ -12,7 +12,7 @@
                ret = phy_ethtool_ksettings_set(pl->phydev, &our_kset);
                if (ret)
                        return ret;
-@@ -1422,8 +1427,11 @@
+@@ -1420,8 +1425,11 @@ int phylink_ethtool_get_eee(struct phyli
  
        ASSERT_RTNL();
  
@@ -25,7 +25,7 @@
  
        return ret;
  }
-@@ -1440,9 +1448,11 @@
+@@ -1438,9 +1446,11 @@ int phylink_ethtool_set_eee(struct phyli
  
        ASSERT_RTNL();