eglibc: fix mips64 abi selection, default to o64 instead of n32
authorFelix Fietkau <nbd@openwrt.org>
Sat, 31 May 2014 12:30:39 +0000 (12:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 31 May 2014 12:30:39 +0000 (12:30 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40888

toolchain/eglibc/common.mk

index f1e3f304559c151d8c027a2e6aff6c3ddde9daf7..81f3df5018e34fd2e9a266d1860377e930b853dd 100644 (file)
@@ -34,6 +34,9 @@ HOST_STAMP_CONFIGURED:=$(CUR_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(CUR_BUILD_DIR)/.built
 HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_$(VARIANT)_installed
 
+ifeq ($(ARCH),mips64)
+  TARGET_CFLAGS += -mabi=64
+endif
 
 EGLIBC_CONFIGURE:= \
        BUILD_CC="$(HOSTCC)" \