x86: add support for AWS T3 instances
authorAlberto Bursi <bobafetthotmail@gmail.com>
Sat, 6 Feb 2021 19:25:32 +0000 (20:25 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Feb 2021 23:34:23 +0000 (00:34 +0100)
Amazon AWS T3 cloud instances require kernel support
for the Elastic Fabric Adapter to access storage
and for Elastic Network Adapter to use network
interfaces.

Since the Fabric Adapter is needed to access
root filesystem, enable in x86_64 kernel.

Elastic Network Adapter goes in a module,
and add this module to default list in x86_64.
The module is set to AutoLoad because AutoProbe does
not seem to load it.

Signed-off-by: Alberto Bursi <bobafetthotmail@gmail.com>
target/linux/x86/64/config-5.4
target/linux/x86/image/64.mk
target/linux/x86/modules.mk

index f09deca5b08b05eb5e3377ed4b16629af4cd1783..d08ff00cb273397a9fb5d0047610593d0e0593d2 100644 (file)
@@ -253,6 +253,7 @@ CONFIG_I2C_BOARDINFO=y
 # CONFIG_I2C_MULTI_INSTANTIATE is not set
 # CONFIG_IA32_EMULATION is not set
 CONFIG_ILLEGAL_POINTER_VALUE=0xdead000000000000
+CONFIG_INFINIBAND_EFA=y
 CONFIG_INPUT_XEN_KBDDEV_FRONTEND=y
 CONFIG_INTEL_GTT=y
 CONFIG_INTEL_IDLE=y
index 745b307585cdb334333de49a241837c8ac4a2bac..edbf5030521d5cb47eab1b9ed34642c85e293707 100644 (file)
@@ -1,7 +1,7 @@
 define Device/generic
   DEVICE_TITLE := Generic x86/64
-  DEVICE_PACKAGES += kmod-bnx2 kmod-e1000e kmod-e1000 kmod-forcedeth kmod-igb \
-       kmod-ixgbe kmod-r8169
+  DEVICE_PACKAGES += kmod-amazon-ena kmod-bnx2 kmod-e1000e kmod-e1000 \
+       kmod-forcedeth kmod-igb kmod-ixgbe kmod-r8169
   GRUB2_VARIANT := generic
 endef
 TARGET_DEVICES += generic
index 24a4384577e398a3839c7b83ce86e65bc6537e00..6ab80d03d918328a8a7c950401227d73b605a8bf 100644 (file)
@@ -2,6 +2,23 @@
 #
 # Copyright (C) 2017 Cezary Jackiewicz <cezary@eko.one.pll>
 
+define KernelPackage/amazon-ena
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Elastic Network Adapter (for Amazon AWS T3)
+  DEPENDS:=@TARGET_x86_64
+  KCONFIG:=CONFIG_ENA_ETHERNET
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/amazon/ena/ena.ko
+  AUTOLOAD:=$(call AutoLoad,12,ena)
+endef
+
+define KernelPackage/amazon-ena/description
+  This driver supports Elastic Network Adapter (ENA)
+  used by Amazon AWS T3 instances.
+endef
+
+$(eval $(call KernelPackage,amazon-ena))
+
+
 define KernelPackage/sound-cs5535audio
   TITLE:=CS5535/CS5536 Audio Controller
   DEPENDS:=@TARGET_x86_geode +kmod-ac97