kernel: bump 4.14 to 4.14.61
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 7 Aug 2018 08:34:37 +0000 (10:34 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 7 Aug 2018 10:53:47 +0000 (12:53 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6, x86_64
Runtime-tested on: cns3xxx, imx6, x86_64

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/mediatek/patches-4.14/0033-dsa-multi-cpu.patch

index 40f2ed8e403f927133048be940a974bce5bc3590..9ffbb2e3066703f30586c7ae786bc87d8d657a79 100644 (file)
@@ -4,13 +4,13 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .121
-LINUX_VERSION-4.14 = .60
 LINUX_VERSION-4.9 = .118
+LINUX_VERSION-4.14 = .61
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
-LINUX_KERNEL_HASH-4.14.60 = 6ce143258fba2e1f543ff56802e047d7d3a741f746b9c947dd088d4a2873b295
 LINUX_KERNEL_HASH-4.9.118 = 7df789e40c6040cd6f6e34326f477b389ab7eaf2bb04940fca4bbe5e733add57
+LINUX_KERNEL_HASH-4.14.61 = 0d0ec521a771e7d393f25b789a06d9af6e2a5a4837fadc04e7048e03b41c70e8
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 5c4edec077b1881723afa33b137e3105d26da92f..926e0d84216924e21fd04e4e8b5db3181c6f49e2 100644 (file)
  
 --- a/net/dsa/slave.c
 +++ b/net/dsa/slave.c
-@@ -1257,7 +1257,7 @@ int dsa_slave_create(struct dsa_port *po
+@@ -1263,7 +1263,7 @@ int dsa_slave_create(struct dsa_port *po
        int ret;
  
        cpu_dp = ds->dst->cpu_dp;
  
        if (!ds->num_tx_queues)
                ds->num_tx_queues = 1;
-@@ -1295,6 +1295,7 @@ int dsa_slave_create(struct dsa_port *po
+@@ -1301,6 +1301,7 @@ int dsa_slave_create(struct dsa_port *po
        p->dp = port;
        INIT_LIST_HEAD(&p->mall_tc_list);
        p->xmit = dst->tag_ops->xmit;