modules: Add kmod-igbvf kernel module for Intel(R) 82576 Virtual Function Ethernet...
authorYe Tao <tydus@hongo.wide.ad.jp>
Sun, 19 Feb 2017 12:57:11 +0000 (21:57 +0900)
committerFelix Fietkau <nbd@nbd.name>
Mon, 3 Apr 2017 06:48:12 +0000 (08:48 +0200)
Intel(R) 82576 is an adapter which supports SR-IOV. Thus the host can
assign Virtual Functions (VFs) to different VMs by the PCI-E Passthrough
(e.g. VFIO for KVM), to gain different advantages (performance, VF to VF
communications, host kernel offload, etc.).

The driver of the passthroughed VFs is the igbvf (igb is NOT
compatible).

This is essential for VM guests, to enable them to utilize this feature.

Signed-off-by: Ye Tao <tydus@hongo.wide.ad.jp>
package/kernel/linux/modules/netdevices.mk

index 9d861d6bda1dd8ae084f3ee5e5d68113738fcb89..4af06c610da5a9e35882760fe849cd1017879c22 100644 (file)
@@ -522,6 +522,24 @@ endef
 $(eval $(call KernelPackage,igb))
 
 
 $(eval $(call KernelPackage,igb))
 
 
+define KernelPackage/igbvf
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Intel(R) 82576 Virtual Function Ethernet support
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-core +kmod-i2c-algo-bit +kmod-ptp
+  KCONFIG:=CONFIG_IGBVF \
+    CONFIG_IGB_HWMON=n \
+    CONFIG_IGB_DCA=n
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/intel/igbvf/igbvf.ko
+  AUTOLOAD:=$(call AutoLoad,35,igbvf)
+endef
+
+define KernelPackage/igbvf/description
+ Kernel modules for Intel(R) 82576 Virtual Function Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,igbvf))
+
+
 define KernelPackage/ixgbe
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Intel(R) 82598/82599 PCI-Express 10 Gigabit Ethernet support
 define KernelPackage/ixgbe
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Intel(R) 82598/82599 PCI-Express 10 Gigabit Ethernet support