kernel: add global menuconfig option to enable kexec support
authorFelix Fietkau <nbd@openwrt.org>
Fri, 28 Jun 2013 11:27:20 +0000 (11:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 28 Jun 2013 11:27:20 +0000 (11:27 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37073

Config.in
target/linux/generic/config-3.10
target/linux/generic/config-3.3
target/linux/generic/config-3.6
target/linux/generic/config-3.7
target/linux/generic/config-3.8
target/linux/generic/config-3.9

index 98e3e04..ef6f1c6 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -303,6 +303,9 @@ menu "Global build settings"
        config KERNEL_RELAY
                bool
 
+       config KERNEL_KEXEC
+               bool "Enable kexec support"
+
        #
        # CGROUP support symbols
        #
index ae6b55d..1e40bdb 100644 (file)
@@ -130,6 +130,7 @@ CONFIG_ARPD=y
 # CONFIG_AT76C50X_USB is not set
 # CONFIG_AT803X_PHY is not set
 # CONFIG_ATA is not set
+CONFIG_ATAGS_PROC=y
 # CONFIG_ATALK is not set
 # CONFIG_ATARI_PARTITION is not set
 # CONFIG_ATA_ACPI is not set
index b4d17ef..5e6d241 100644 (file)
@@ -117,6 +117,7 @@ CONFIG_ARPD=y
 # CONFIG_ASYNC_TX_DMA is not set
 # CONFIG_AT76C50X_USB is not set
 # CONFIG_ATA is not set
+CONFIG_ATAGS_PROC=y
 # CONFIG_ATALK is not set
 # CONFIG_ATARI_PARTITION is not set
 # CONFIG_ATA_ACPI is not set
index 712dded..b8340da 100644 (file)
@@ -120,6 +120,7 @@ CONFIG_ARPD=y
 # CONFIG_ASYNC_TX_DMA is not set
 # CONFIG_AT76C50X_USB is not set
 # CONFIG_ATA is not set
+CONFIG_ATAGS_PROC=y
 # CONFIG_ATALK is not set
 # CONFIG_ATARI_PARTITION is not set
 # CONFIG_ATA_ACPI is not set
index d773394..c719e39 100644 (file)
@@ -124,6 +124,7 @@ CONFIG_ARPD=y
 # CONFIG_AT76C50X_USB is not set
 # CONFIG_AT803X_PHY is not set
 # CONFIG_ATA is not set
+CONFIG_ATAGS_PROC=y
 # CONFIG_ATALK is not set
 # CONFIG_ATARI_PARTITION is not set
 # CONFIG_ATA_ACPI is not set
index 7a0b415..b479e4e 100644 (file)
@@ -128,6 +128,7 @@ CONFIG_ARPD=y
 # CONFIG_AT76C50X_USB is not set
 # CONFIG_AT803X_PHY is not set
 # CONFIG_ATA is not set
+CONFIG_ATAGS_PROC=y
 # CONFIG_ATALK is not set
 # CONFIG_ATARI_PARTITION is not set
 # CONFIG_ATA_ACPI is not set
index a6a801a..d88286f 100644 (file)
@@ -130,6 +130,7 @@ CONFIG_ARPD=y
 # CONFIG_AT76C50X_USB is not set
 # CONFIG_AT803X_PHY is not set
 # CONFIG_ATA is not set
+CONFIG_ATAGS_PROC=y
 # CONFIG_ATALK is not set
 # CONFIG_ATARI_PARTITION is not set
 # CONFIG_ATA_ACPI is not set