kernel: when disabling common quirks, disable them in the usb subsystem as well ...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 27 Feb 2011 19:52:43 +0000 (19:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 27 Feb 2011 19:52:43 +0000 (19:52 +0000)
SVN-Revision: 25768

target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch [new file with mode: 0644]
target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch [new file with mode: 0644]

diff --git a/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch
new file mode 100644 (file)
index 0000000..49954bb
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
+ obj-$(CONFIG_USB_WHCI_HCD)    += whci/
++ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
+ obj-$(CONFIG_PCI)             += pci-quirks.o
++endif
+ obj-$(CONFIG_USB_EHCI_HCD)    += ehci-hcd.o
+ obj-$(CONFIG_USB_OXU210HP_HCD)        += oxu210hp-hcd.o
diff --git a/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch
new file mode 100644 (file)
index 0000000..49954bb
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
+ obj-$(CONFIG_USB_WHCI_HCD)    += whci/
++ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
+ obj-$(CONFIG_PCI)             += pci-quirks.o
++endif
+ obj-$(CONFIG_USB_EHCI_HCD)    += ehci-hcd.o
+ obj-$(CONFIG_USB_OXU210HP_HCD)        += oxu210hp-hcd.o