brcm63xx: Add DT support for VR-3025un
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:34 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:34 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
[jogo: make linux partition writable]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42242

target/linux/brcm63xx/dts/vr-3025un.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/comtrend.mk

diff --git a/target/linux/brcm63xx/dts/vr-3025un.dts b/target/linux/brcm63xx/dts/vr-3025un.dts
new file mode 100644 (file)
index 0000000..6fc0c2a
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6368.dtsi"
+
+/ {
+       model = "Comtrend VR-3025un";
+       compatible = "comtrend,vr-3025un", "brcm,bcm6368";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x7e0000>;
+       };
+
+       nvram@7f0000 {
+               label = "nvram";
+               reg = <0x7f0000 0x010000>;
+       };
+};
index fc759785dc36071a989c0f9cd66066329498da30..9c8deb61f62590f13f3a62e9c77201a416975ef3 100755 (executable)
@@ -271,8 +271,6 @@ define Image/Build
        # Sagem F@ST2504n
        $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
 
-       # Comtrend VR-3025un
-       $(call Image/Build/CFE,$(1),96368M-1341N,6368,VR-3025un,,--pad 4)
        # Comtrend WAP-5813n
        $(call Image/Build/CFE,$(1),96369R-1231N,6368,WAP-5813n,,--pad 4)
        # Davolink DV201AMR
@@ -363,6 +361,8 @@ $(eval $(call CfeImageDTB,CT5365,ct-5365,96348A-122,6348,CT-5365))
 $(eval $(call CfeImageDTB,CT6373,ct-6373,CT6373-1,6358,CT-6373))
 # Comtrend VR-3025u
 $(eval $(call CfeImageDTB,VR3025u,vr-3025u,96368M-1541N,6368,VR-3025u,,--pad 16 --image-offset 0x20000 --block-size 0x20000))
+# Comtrend VR-3025un
+$(eval $(call CfeImageDTB,VR3025un,vr-3025un,96368M-1341N,6368,VR-3025un,,--pad 4))
 # D-Link DSL-2740B/DSL-2741B, rev C2
 $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
 # D-Link DSL-2740B/DSL-2741B, rev C3
index 5b18b72e4582e80c29c8f05be0339dbecb0eecb2..8e25172f2059262b7960f96136334e1ae986bd4b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4280,6 +4280,116 @@ static struct board_info __initdata boar
+@@ -4280,6 +4280,117 @@ static struct board_info __initdata boar
        },
  };
  
@@ -15,6 +15,7 @@
 +
 +static struct board_info __initdata board_VR3025un = {
 +      .name                                   = "96368M-1341N",
++      .of_board_id                    = "comtrend,vr-3025un",
 +      .expected_cpu_id                = 0x6368,
 +
 +      .has_uart0                              = 1,
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4770,6 +4880,7 @@ static const struct board_info __initcon
+@@ -4770,6 +4881,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 3ee2dd5d7ad5b20f29e40010a22cc2ac3460bf9d..35ee212502b9a597c9e7e5db95b9f0b82f99373c 100644 (file)
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
-@@ -4879,6 +4969,7 @@ static const struct board_info __initcon
+@@ -4880,6 +4970,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index a686ef6a8d8b30addd6e9a8c2ba0483ff5a74b1b..5f5d77118f0eb52c786a2b2ce6001f139cd8cd3e 100644 (file)
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -4953,6 +5003,7 @@ static const struct board_info __initcon
+@@ -4954,6 +5004,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 0fbb1758dbaa0e7c09ab5b989703888c56e91958..1f2214f035336e23c07904c33d923919bc373506 100644 (file)
@@ -96,7 +96,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -4954,6 +5043,7 @@ static const struct board_info __initcon
+@@ -4955,6 +5044,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 2bb41de61a64fe00b00913acbbb3b7313e0224d5..9e524433e1f255b5015a2190c8c1a12349b34e8e 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5037,6 +5172,7 @@ static const struct board_info __initcon
+@@ -5038,6 +5173,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index ab9b61253c473b4f76d905918844139ec0ea59db..b3495b13be404745d85b9030d0c98ab3f43912ba 100644 (file)
@@ -62,3 +62,13 @@ define Profile/VR3025u/Description
   Package set optimized for VR-3025u.
 endef
 $(eval $(call Profile,VR3025u))
+
+define Profile/VR3025un
+  NAME:=Comtrend VR-3025un
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/VR3025un/Description
+  Package set optimized for VR-3025un.
+endef
+$(eval $(call Profile,VR3025un))