kernel: bump 4.14 to 4.14.13
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 10 Jan 2018 14:06:52 +0000 (14:06 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 11 Jan 2018 19:34:33 +0000 (20:34 +0100)
Refresh patches

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
include/kernel-version.mk
target/linux/octeon/patches-4.14/110-er200-ethernet_probe_order.patch
target/linux/octeon/patches-4.14/160-cmdline-hack.patch
target/linux/octeon/patches-4.14/170-cisco-hack.patch

index e605dd0a6e3931c277a17e9d44490d3d7e1825a1..87d3ff172d139665e156914a1a66b131908936b7 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .111
 LINUX_VERSION-4.9 = .76
-LINUX_VERSION-4.14 = .12
+LINUX_VERSION-4.14 = .13
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.111 = a201282e8eaf62b4f51edb2241e98ff805fe2d1b04a72a2328c5a6e2d77ec008
 LINUX_KERNEL_HASH-4.9.76 = b82b94332cffaaeade74495264c989dafb96d4748503f87a5b7c436f5de887de
-LINUX_KERNEL_HASH-4.14.12 = 6608f7d480efc5c1078888e9344f4e0b0cd9bef0b6541cbdaec7d138e03856af
+LINUX_KERNEL_HASH-4.14.13 = 4ab46d1b5a0f8ef83b80760f89ae4f5c88431b19b3cf79ffa0c66d6b33e45772
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 1df3f6a67554e9df2d33c5312a6c2282b4099804..6b1eaf92a2b0c06b7e416700437898f2513e89ab 100644 (file)
@@ -1,14 +1,14 @@
 --- a/drivers/staging/octeon/ethernet.c
 +++ b/drivers/staging/octeon/ethernet.c
-@@ -684,6 +684,7 @@ static int cvm_oct_probe(struct platform
+@@ -673,6 +673,7 @@ static int cvm_oct_probe(struct platform
        int interface;
        int fau = FAU_NUM_PACKET_BUFFERS_TO_FREE;
        int qos;
 +      int i;
        struct device_node *pip;
+       int mtu_overhead = ETH_HLEN + ETH_FCS_LEN;
  
-       octeon_mdiobus_force_mod_depencency();
-@@ -800,13 +801,19 @@ static int cvm_oct_probe(struct platform
+@@ -796,13 +797,19 @@ static int cvm_oct_probe(struct platform
        }
  
        num_interfaces = cvmx_helper_get_number_of_interfaces();
index 2a4ad1dc73a1c6355839f895cc13938851a56a10..e902e853e820fd69d91016d5726fd0ae1894f1fa 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/cavium-octeon/setup.c
 +++ b/arch/mips/cavium-octeon/setup.c
-@@ -656,6 +656,35 @@ void octeon_user_io_init(void)
+@@ -650,6 +650,35 @@ void octeon_user_io_init(void)
        write_c0_derraddr1(0);
  }
  
  /**
   * Early entry point for arch setup
   */
-@@ -900,6 +929,8 @@ void __init prom_init(void)
+@@ -894,6 +923,8 @@ void __init prom_init(void)
                }
        }
  
 +      octeon_use_image_cmdline();
 +
        if (strstr(arcs_cmdline, "console=") == NULL) {
- #ifdef CONFIG_CAVIUM_OCTEON_2ND_KERNEL
-               strcat(arcs_cmdline, " console=ttyS0,115200");
+               if (octeon_uart == 1)
+                       strcat(arcs_cmdline, " console=ttyS1,115200");
index 124bcfd7a7af7ef670d355bc99e47c0d96e0c20d..72774209dc354b77bf8a4af3afe90d7110b4c1a5 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: MichaƂ Osowiecki <michal.osowiecki@gmail.com>
 
 --- a/arch/mips/cavium-octeon/setup.c
 +++ b/arch/mips/cavium-octeon/setup.c
-@@ -1005,6 +1005,10 @@ void __init plat_mem_setup(void)
+@@ -1018,6 +1018,10 @@ void __init plat_mem_setup(void)
        if (mem_alloc_size > max_memory)
                mem_alloc_size = max_memory;