metadata: add "metadata_version" field
authorPaul Spooren <mail@aparcar.org>
Tue, 5 Mar 2019 23:32:45 +0000 (00:32 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 6 Mar 2019 00:11:54 +0000 (01:11 +0100)
allow downstream projects to see the current version of the metadata,
usefull if eventually more variables change

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/image-commands.mk

index c0bda2084c852098730782fce8148acf511f5c6f..8251a814000d2507676ccf51075860e86f64da18 100644 (file)
@@ -355,6 +355,7 @@ json_quote=$(subst ','\'',$(subst ",\",$(1)))
 metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))
 metadata_json = \
        '{ $(if $(IMAGE_METADATA),$(IMAGE_METADATA)$(comma)) \
+               "metadata_version": "1.0", \
                "supported_devices":[$(call metadata_devices,$(1))], \
                "version": { \
                        "dist": "$(call json_quote,$(VERSION_DIST))", \