mvebu: Add bootscript for espressobin to support mainline firmware
authorAndre Heider <a.heider@gmail.com>
Sat, 12 Sep 2020 07:32:41 +0000 (09:32 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 28 Oct 2020 22:22:44 +0000 (23:22 +0100)
The generic bootscript is tailored around a downstream firmware and
doesn't work on a firmware built from mainline components.

Add a bootscript which:
* sets $console since mainline u-boot doesn't do that
* uses distro boot variables, so OpenWRT can be booted off any supported
  device when using a mainline firmware
* sets missing distro boot variables for the downstream firmware

Booting with a downstream firmware is unchanged.
Booting with a mainline firmware now works.

Signed-off-by: Andre Heider <a.heider@gmail.com>
(cherry picked from commit c43b45863e38fb18a486601c1601f1485d649c0b)

target/linux/mvebu/image/cortex-a53.mk
target/linux/mvebu/image/espressobin.bootscript [new file with mode: 0644]

index d7014d6f027a37e4e7c89613953b1a95d94964ca..7b3bcba06ded191716fd782f4cc47e567ecf63a3 100644 (file)
@@ -4,6 +4,7 @@ define Device/globalscale_espressobin
   $(call Device/Default-arm64)
   DEVICE_TITLE := ESPRESSObin (Marvell Armada 3700 Community Board)
   DEVICE_DTS := armada-3720-espressobin
+  BOOT_SCRIPT := espressobin
 endef
 TARGET_DEVICES += globalscale_espressobin
 
@@ -11,6 +12,7 @@ define Device/globalscale_espressobin-emmc
   $(call Device/Default-arm64)
   DEVICE_TITLE := ESPRESSObin eMMC (Marvell Armada 3700 Community Board)
   DEVICE_DTS := armada-3720-espressobin-emmc
+  BOOT_SCRIPT := espressobin
 endef
 TARGET_DEVICES += globalscale_espressobin-emmc
 
@@ -18,6 +20,7 @@ define Device/globalscale_espressobin-v7
   $(call Device/Default-arm64)
   DEVICE_TITLE := ESPRESSObin V7 (Marvell Armada 3700 Community Board)
   DEVICE_DTS := armada-3720-espressobin-v7
+  BOOT_SCRIPT := espressobin
 endef
 TARGET_DEVICES += globalscale_espressobin-v7
 
@@ -25,6 +28,7 @@ define Device/globalscale_espressobin-v7-emmc
   $(call Device/Default-arm64)
   DEVICE_TITLE := ESPRESSObin V7 eMMC (Marvell Armada 3700 Community Board)
   DEVICE_DTS := armada-3720-espressobin-v7-emmc
+  BOOT_SCRIPT := espressobin
 endef
 TARGET_DEVICES += globalscale_espressobin-v7-emmc
 
diff --git a/target/linux/mvebu/image/espressobin.bootscript b/target/linux/mvebu/image/espressobin.bootscript
new file mode 100644 (file)
index 0000000..07765df
--- /dev/null
@@ -0,0 +1,34 @@
+# Bootscript for Globalscale ESPRESSOBin Board
+
+# Set distro variables if necessary for compability with downstream firmware
+if test -z "${kernel_addr_r}"; then
+       setenv kernel_addr_r 0x7000000
+fi
+
+if test -z "${fdt_add_r}"; then
+       setenv fdt_addr_r 0x6f00000
+fi
+
+if test -z "${devtype}"; then
+       setenv devtype mmc
+fi
+
+if test -z "${devnum}"; then
+       if mmc dev 0; then
+               setenv devnum 0
+       elif mmc dev 1; then
+               setenv devnum 1
+       fi
+fi
+
+# figure out partition uuid to pass to the kernel as root=
+part uuid ${devtype} ${devnum}:2 uuid
+
+setenv console "console=ttyMV0,115200 earlycon=ar3700_uart,0xd0012000"
+setenv bootargs "root=PARTUUID=${uuid} rw rootwait ${console}"
+
+echo "Booting Linux from ${devtype} ${devnum} with args: ${bootargs}"
+load ${devtype} ${devnum}:1 ${fdt_addr_r} @DTB@.dtb
+load ${devtype} ${devnum}:1 ${kernel_addr_r} Image
+
+booti ${kernel_addr_r} - ${fdt_addr_r}