x86: build fully functional images on Mac OS X, now that grub is fixed
authorFelix Fietkau <nbd@openwrt.org>
Fri, 28 May 2010 19:48:21 +0000 (19:48 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 28 May 2010 19:48:21 +0000 (19:48 +0000)
SVN-Revision: 21609

target/linux/x86/image/Makefile

index 2c4cc350e5dab2d5a28afad790ed1dbd876eaf9b..338c8e0a7492649e1c3e48ecc5f0f2cfe4f5be45 100644 (file)
@@ -32,7 +32,6 @@ endif
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 
 ifneq ($(CONFIG_X86_GRUB_IMAGES),)
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 
 ifneq ($(CONFIG_X86_GRUB_IMAGES),)
- ifneq ($(HOST_OS),Darwin)
 
   BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
 
 
   BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
 
@@ -83,16 +82,6 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
                $(KDIR)/
   endef
 
                $(KDIR)/
   endef
 
- else
-
-  define Image/Build/grub
-       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" NOGRUB=1 ./gen_image_x86.sh \
-               $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-               $(CONFIG_TARGET_KERNEL_PARTSIZE) "" \
-               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
-  endef
-
- endif
 endif
 
 ROOTDELAY=10
 endif
 
 ROOTDELAY=10