add binutils 2.19 (patch from #4367)
authorFelix Fietkau <nbd@openwrt.org>
Sat, 17 Jan 2009 19:29:09 +0000 (19:29 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 17 Jan 2009 19:29:09 +0000 (19:29 +0000)
SVN-Revision: 14075

toolchain/binutils/Config.in
toolchain/binutils/Makefile
toolchain/binutils/patches/2.19/110-arm-eabi-conf.patch [new file with mode: 0644]
toolchain/binutils/patches/2.19/120-sh-conf.patch [new file with mode: 0644]
toolchain/binutils/patches/2.19/300-001_ld_makefile_patch.patch [new file with mode: 0644]
toolchain/binutils/patches/2.19/300-012_check_ldrunpath_length.patch [new file with mode: 0644]

index 3a28b6553d8a0805d30b2b50528b957303749670..4dce6ca126d0620c22d011902815495f903df15c 100644 (file)
@@ -13,6 +13,9 @@ choice
        config BINUTILS_VERSION_2_18
                bool "binutils 2.18"
 
+       config BINUTILS_VERSION_2_19
+               bool "binutils 2.19"
+
 endchoice
 
 config EXTRA_BINUTILS_CONFIG_OPTIONS
@@ -27,5 +30,6 @@ config BINUTILS_VERSION
        prompt "Binutils Version" if (TOOLCHAINOPTS && NULL)
        default "2.17"            if BINUTILS_VERSION_2_17
        default "2.18"            if BINUTILS_VERSION_2_18
+       default "2.19"            if BINUTILS_VERSION_2_19
        default "2.18"            if TARGET_avr32
        default "2.17"
index db3ea75d444610f6dd90b7ac953c580079e6b420..e6f60a846c293a06c0928579409eea2c7972370b 100644 (file)
@@ -18,6 +18,9 @@ endif
 ifeq ($(PKG_VERSION),2.18)
   PKG_MD5SUM:=9d22ee4dafa3a194457caf4706f9cf01
 endif
+ifeq ($(PKG_VERSION),2.19)
+  PKG_MD5SUM:=17a52219dee5a76c1a9d9b0bfd337d66
+endif
 
 PATCH_DIR:=./patches/$(PKG_VERSION)
 
diff --git a/toolchain/binutils/patches/2.19/110-arm-eabi-conf.patch b/toolchain/binutils/patches/2.19/110-arm-eabi-conf.patch
new file mode 100644 (file)
index 0000000..af26329
--- /dev/null
@@ -0,0 +1,24 @@
+diff -rdup binutils-2.18.50.0.3.orig/configure binutils-2.18.50.0.3/configure
+--- binutils-2.18.50.0.3.orig/configure        2007-11-22 12:41:26.000000000 +0100
++++ binutils-2.18.50.0.3/configure     2007-11-22 12:45:01.000000000 +0100
+@@ -2245,7 +2245,7 @@ case "${target}" in
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     libgloss_dir=arm
+     ;;
+-  arm*-*-linux-gnueabi)
++  arm*-*-linux-*gnueabi)
+     noconfigdirs="$noconfigdirs target-qthreads"
+     noconfigdirs="$noconfigdirs target-libobjc"
+     case ${with_newlib} in
+diff -rdup binutils-2.18.50.0.3.orig/configure.ac binutils-2.18.50.0.3/configure.ac
+--- binutils-2.18.50.0.3.orig/configure.ac     2007-11-22 12:41:26.000000000 +0100
++++ binutils-2.18.50.0.3/configure.ac  2007-11-22 12:44:54.000000000 +0100
+@@ -522,7 +522,7 @@ case "${target}" in
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     libgloss_dir=arm
+     ;;
+-  arm*-*-linux-gnueabi)
++  arm*-*-linux-*gnueabi)
+     noconfigdirs="$noconfigdirs target-qthreads"
+     noconfigdirs="$noconfigdirs target-libobjc"
+     case ${with_newlib} in
diff --git a/toolchain/binutils/patches/2.19/120-sh-conf.patch b/toolchain/binutils/patches/2.19/120-sh-conf.patch
new file mode 100644 (file)
index 0000000..071d15a
--- /dev/null
@@ -0,0 +1,42 @@
+diff -rdup binutils-2.18.50.0.9.old/configure binutils-2.18.50.0.9/configure
+--- binutils-2.18.50.0.9.old/configure 2008-08-23 17:36:13.000000000 +0200
++++ binutils-2.18.50.0.9/configure     2008-10-14 14:25:22.000000000 +0200
+@@ -2281,7 +2281,7 @@ case "${target}" in
+   am33_2.0-*-linux*)
+     noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+     ;;
+-  sh-*-linux*)
++  sh*-*-linux*)
+     noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+     ;;
+   sh*-*-pe|mips*-*-pe|*arm-wince-pe)
+@@ -2606,7 +2606,7 @@ case "${target}" in
+   romp-*-*)
+     noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
+     ;;
+-  sh-*-* | sh64-*-*)
++  sh*-*-* | sh64-*-*)
+     case "${host}" in
+       i[3456789]86-*-vsta) ;; # don't add gprof back in
+       i[3456789]86-*-go32*) ;; # don't add gprof back in
+diff -rdup binutils-2.18.50.0.9.old/configure.ac binutils-2.18.50.0.9/configure.ac
+--- binutils-2.18.50.0.9.old/configure.ac      2008-08-23 17:36:13.000000000 +0200
++++ binutils-2.18.50.0.9/configure.ac  2008-10-14 14:25:11.000000000 +0200
+@@ -530,7 +530,7 @@ case "${target}" in
+   am33_2.0-*-linux*)
+     noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+     ;;
+-  sh-*-linux*)
++  sh*-*-linux*)
+     noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+     ;;    
+   sh*-*-pe|mips*-*-pe|*arm-wince-pe)
+@@ -855,7 +855,7 @@ case "${target}" in
+   romp-*-*)
+     noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
+     ;;
+-  sh-*-* | sh64-*-*)
++  sh*-*-* | sh64-*-*)
+     case "${host}" in
+       i[[3456789]]86-*-vsta) ;; # don't add gprof back in
+       i[[3456789]]86-*-go32*) ;; # don't add gprof back in
diff --git a/toolchain/binutils/patches/2.19/300-001_ld_makefile_patch.patch b/toolchain/binutils/patches/2.19/300-001_ld_makefile_patch.patch
new file mode 100644 (file)
index 0000000..5cb0f61
--- /dev/null
@@ -0,0 +1,24 @@
+diff -u binutils-2.17.50.0.17.oorig/ld/Makefile.am binutils-2.17.50.0.17/ld/Makefile.am
+--- binutils-2.17.50.0.17.oorig/ld/Makefile.am 2007-06-18 19:29:29.000000000 +0200
++++ binutils-2.17.50.0.17/ld/Makefile.am       2007-06-25 10:00:36.000000000 +0200
+@@ -18,7 +18,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+diff -u binutils-2.17.50.0.17.oorig/ld/Makefile.in binutils-2.17.50.0.17/ld/Makefile.in
+--- binutils-2.17.50.0.17.oorig/ld/Makefile.in 2007-06-18 19:29:29.000000000 +0200
++++ binutils-2.17.50.0.17/ld/Makefile.in       2007-06-25 10:00:36.000000000 +0200
+@@ -287,7 +287,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/patches/2.19/300-012_check_ldrunpath_length.patch b/toolchain/binutils/patches/2.19/300-012_check_ldrunpath_length.patch
new file mode 100644 (file)
index 0000000..6e80921
--- /dev/null
@@ -0,0 +1,21 @@
+diff -u binutils-2.17.50.0.17.oorig/ld/emultempl/elf32.em binutils-2.17.50.0.17/ld/emultempl/elf32.em
+--- binutils-2.17.50.0.17.oorig/ld/emultempl/elf32.em  2007-06-18 19:31:40.000000000 +0200
++++ binutils-2.17.50.0.17/ld/emultempl/elf32.em        2007-06-25 10:01:25.000000000 +0200
+@@ -1007,6 +1007,8 @@
+             && command_line.rpath == NULL)
+           {
+             lib_path = (const char *) getenv ("LD_RUN_PATH");
++            if ((lib_path) && (strlen (lib_path) == 0))
++                lib_path = NULL;
+             if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
+                                                     force))
+               break;
+@@ -1191,6 +1193,8 @@
+   rpath = command_line.rpath;
+   if (rpath == NULL)
+     rpath = (const char *) getenv ("LD_RUN_PATH");
++  if ((rpath) && (strlen (rpath) == 0))
++      rpath = NULL;
+   if (! (bfd_elf_size_dynamic_sections
+        (output_bfd, command_line.soname, rpath,
+         command_line.filter_shlib,