kernel: add kmod-sound-ens1371
authorFelix Fietkau <nbd@nbd.name>
Wed, 21 Mar 2018 17:49:29 +0000 (18:49 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sun, 25 Mar 2018 19:18:35 +0000 (21:18 +0200)
This audio chip is provided as a virtual audio device by VMware

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/sound.mk

index faee1f3674ef144021393b0825bf9434a8b1998a..177140e0fc181d7408b452f558a187fb467cde2f 100644 (file)
@@ -135,6 +135,22 @@ endef
 $(eval $(call KernelPackage,sound-seq))
 
 
+define KernelPackage/sound-ens1371
+  TITLE:=(Creative) Ensoniq AudioPCI 1371
+  KCONFIG:=CONFIG_SND_ENS1371
+  DEPENDS:=@PCI_SUPPORT +kmod-ac97
+  FILES:=$(LINUX_DIR)/sound/pci/snd-ens1371.ko
+  AUTOLOAD:=$(call AutoLoad,36,snd-ens1371)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-ens1371/description
+ support for (Creative) Ensoniq AudioPCI 1371 chips
+endef
+
+$(eval $(call KernelPackage,sound-ens1371))
+
+
 define KernelPackage/sound-i8x0
   TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
   DEPENDS:=+kmod-ac97