kernel: bump 4.9 to 4.9.144
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 10 Dec 2018 11:39:53 +0000 (12:39 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 10 Dec 2018 15:32:22 +0000 (16:32 +0100)
Refreshed all patches.

Remove upstreamed:
- 014-Kbuild-suppress-packed-not-aligned-warning-for-defau.patch

Compile-tested: ar7, brcm2708
Runtime-tested: none

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/014-Kbuild-suppress-packed-not-aligned-warning-for-defau.patch [deleted file]
target/linux/generic/hack-4.9/207-disable-modorder.patch

index 42f6ad8633ed5dea75efd4d815ed7938b5aeb046..aba634f3bfef225ed6b08373213c040f0177590e 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .128
-LINUX_VERSION-4.9 = .143
+LINUX_VERSION-4.9 = .144
 LINUX_VERSION-4.14 = .86
 
 LINUX_KERNEL_HASH-3.18.128 = 396368ef7eadf639c6f62ef43ea9c63a05280f926f731c3a86b0aa0e2b3ad2e3
-LINUX_KERNEL_HASH-4.9.143 = 0eb76464a696675fd4f8762e390328a377e973bfa263b00544ca1b5b10ac2cbf
+LINUX_KERNEL_HASH-4.9.144 = 05d17f434d22e9fa2f9084cdf6858383564883d23a1d11ce4dae4b217662782b
 LINUX_KERNEL_HASH-4.14.86 = da9260a9022b917733201b89b5314847cb3332c31e70acb5e9b547956c266e28
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/generic/backport-4.9/014-Kbuild-suppress-packed-not-aligned-warning-for-defau.patch b/target/linux/generic/backport-4.9/014-Kbuild-suppress-packed-not-aligned-warning-for-defau.patch
deleted file mode 100644 (file)
index a6e312a..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-From: Xiongfeng Wang <xiongfeng.wang@linaro.org>
-Date: Thu, 11 Jan 2018 17:22:29 +0800
-Subject: [PATCH] Kbuild: suppress packed-not-aligned warning for default
- setting only
-
-gcc-8 reports many -Wpacked-not-aligned warnings. The below are some
-examples.
-
-./include/linux/ceph/msgr.h:67:1: warning: alignment 1 of 'struct
-ceph_entity_addr' is less than 8 [-Wpacked-not-aligned]
- } __attribute__ ((packed));
-
-./include/linux/ceph/msgr.h:67:1: warning: alignment 1 of 'struct
-ceph_entity_addr' is less than 8 [-Wpacked-not-aligned]
- } __attribute__ ((packed));
-
-./include/linux/ceph/msgr.h:67:1: warning: alignment 1 of 'struct
-ceph_entity_addr' is less than 8 [-Wpacked-not-aligned]
- } __attribute__ ((packed));
-
-This patch suppresses this kind of warnings for default setting.
-
-Signed-off-by: Xiongfeng Wang <xiongfeng.wang@linaro.org>
-Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
----
-
---- a/scripts/Makefile.extrawarn
-+++ b/scripts/Makefile.extrawarn
-@@ -10,6 +10,8 @@
- # are not supported by all versions of the compiler
- # ==========================================================================
-+KBUILD_CFLAGS += $(call cc-disable-warning, packed-not-aligned)
-+
- ifeq ("$(origin W)", "command line")
-   export KBUILD_ENABLE_EXTRA_GCC_CHECKS := $(W)
- endif
-@@ -25,6 +27,7 @@ warning-1 += -Wold-style-definition
- warning-1 += $(call cc-option, -Wmissing-include-dirs)
- warning-1 += $(call cc-option, -Wunused-but-set-variable)
- warning-1 += $(call cc-option, -Wunused-const-variable)
-+warning-1 += $(call cc-option, -Wpacked-not-aligned)
- warning-1 += $(call cc-disable-warning, missing-field-initializers)
- warning-1 += $(call cc-disable-warning, sign-compare)
index e92f4fa0bf31b47a22b3c258f54303a0e69d8d06..025a18bccdfb93348ebc0269c61d5f059d998f79 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1226,7 +1226,6 @@ all: modules
+@@ -1229,7 +1229,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1256,7 +1255,6 @@ _modinst_:
+@@ -1259,7 +1258,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi