6in4: fix invalid local variable declaration (FS#188)
authorJo-Philipp Wich <jo@mein.io>
Tue, 27 Sep 2016 14:20:57 +0000 (16:20 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 27 Sep 2016 14:23:06 +0000 (16:23 +0200)
Remove an invalid local variable declaration in the tunnel update subshell
invocation. Local declarations outside of function scopes are illegal since
the Busybox update to version 1.25.0 .

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index 5d9355fa540cdf66836165bf7905db3c2046f87d..34227ce9ef52d56010b48acb670e6ee22706a9df 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=23
+PKG_VERSION:=24
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
@@ -19,7 +19,7 @@ define Package/6in4
   CATEGORY:=Network
   DEPENDS:=@IPV6 +kmod-sit +uclient-fetch
   TITLE:=IPv6-in-IPv4 configuration support
-  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+  MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
   PKGARCH:=all
 endef
 
index c358a222fa355fcf2d196cfa3535df7fbc7b8646..45d8ab75ad4d52ab5021c4baf0f96b3c6c124ffa 100755 (executable)
@@ -11,7 +11,7 @@
 
 proto_6in4_update() {
        sh -c '
-               local timeout=5
+               timeout=5
 
                (while [ $((timeout--)) -gt 0 ]; do
                        sleep 1