image: when using the new image build code, gzip ext4 images by default
authorFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 14:58:37 +0000 (15:58 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 15:59:28 +0000 (16:59 +0100)
This reduces the amount of hacks in the makefile code.

Remove the apm821xx code to do the same - it was broken and left both
compressed and uncompressed images in $(BIN_DIR)

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image.mk
target/linux/apm821xx/image/Makefile

index ab5b816844e7cabe2271d3bcd5707224a0534271..4bd923fea82cda7c9eed3309a4949dcf76a58a11 100644 (file)
@@ -445,7 +445,8 @@ define Device/Build/kernel
 endef
 
 define Device/Build/image
 endef
 
 define Device/Build/image
-  $$(_TARGET): $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))
+  GZ_SUFFIX := $(if $(filter %dtb %gz,$(2)),,$(if $(and $(findstring ext4,$(1)),$(CONFIG_TARGET_IMAGES_GZIP)),.gz))
+  $$(_TARGET): $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))$$(GZ_SUFFIX)
   $(eval $(call Device/Export,$(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)),$(1)))
   ROOTFS/$(1)/$(3) := \
        $(KDIR)/root.$(1)$$(strip \
   $(eval $(call Device/Export,$(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)),$(1)))
   ROOTFS/$(1)/$(3) := \
        $(KDIR)/root.$(1)$$(strip \
@@ -462,6 +463,10 @@ define Device/Build/image
        $$(call concat_cmd,$(if $(IMAGE/$(2)/$(1)),$(IMAGE/$(2)/$(1)),$(IMAGE/$(2))))
 
   .IGNORE: $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))
        $$(call concat_cmd,$(if $(IMAGE/$(2)/$(1)),$(IMAGE/$(2)/$(1)),$(IMAGE/$(2))))
 
   .IGNORE: $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))
+
+  $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2)).gz: $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2))
+       gzip -c -9n $$^ > $$@
+
   $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2))
        cp $$^ $$@
 
   $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2))
        cp $$^ $$@
 
index 0ee9cdcd173bdbca139bd2453d014a5bccf74429..0ded83dd9995bb3739ea6b769c17d60ba438b03b 100644 (file)
@@ -232,7 +232,6 @@ endef
 
 define Build/hdd-img
        ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS)
 
 define Build/hdd-img
        ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS)
-       $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
 
 define Device/MyBookLiveDefault
 endef
 
 define Device/MyBookLiveDefault