base-files: remove fstab symlink
authorJohn Crispin <john@phrozen.org>
Thu, 16 Jun 2016 22:54:25 +0000 (00:54 +0200)
committerJohn Crispin <john@phrozen.org>
Fri, 17 Jun 2016 02:13:07 +0000 (04:13 +0200)
the symlink no longer gets used since we switched to the block-mount tool.

Signed-off-by: John Crispin <john@phrozen.org>
package/base-files/Makefile
package/base-files/files/etc/fstab [new file with mode: 0644]

index 1334d80d5dfdffa011fe16b3659e34871d4cc6f1..e51d65ac4260cd6abcf255e87537a35b858bc59f 100644 (file)
@@ -169,7 +169,7 @@ define Package/base-files/install
        rm -f $(1)/var
        $(LN) /tmp $(1)/var
        mkdir -p $(1)/etc
-       $(LN) /tmp/resolv.conf /tmp/fstab /tmp/TZ /tmp/localtime $(1)/etc/
+       $(LN) /tmp/resolv.conf /tmp/TZ /tmp/localtime $(1)/etc/
 
        chmod 0600 $(1)/etc/shadow
        chmod 1777 $(1)/tmp
diff --git a/package/base-files/files/etc/fstab b/package/base-files/files/etc/fstab
new file mode 100644 (file)
index 0000000..6e9b7ba
--- /dev/null
@@ -0,0 +1 @@
+# <file system> <mount point> <type> <options> <dump> <pass>