kernel: add kmod-leds-turris-omnia
authorStefan Kalscheuer <stefan@stklcode.de>
Thu, 19 May 2022 19:10:34 +0000 (21:10 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 16 Aug 2022 13:20:28 +0000 (15:20 +0200)
Add support for LEDs of the CZ.NIC Turris Omnia using the upstream
driver.

There is no generic way to control the LEDs in UCI manner, however
the kernel module is the first step to actually use the RGB LEDs in
custom logic.

Signed-off-by: Stefan Kalscheuer <stefan@stklcode.de>
(removed DMARC notice, added driver to Turris Omnia, moved module
recipe to target/linux/mvebu/modules.mk)
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
(cherry picked from commit f8fa38c13fcc3b4ce9a4dfc56d98e5188353afac)
Reviewed-by: Robert Marko <robimarko@gmail.com>
target/linux/mvebu/image/cortexa9.mk
target/linux/mvebu/modules.mk

index b06c5594bd349d0d9430cad0dbc2e843f74832fe..d9738903fb0413113984bd43c7eae4768ed3a51e 100644 (file)
@@ -59,7 +59,7 @@ define Device/cznic_turris-omnia
   DEVICE_PACKAGES :=  \
     mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
     wpad-basic-wolfssl kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
-    partx-utils kmod-i2c-mux-pca954x
+    partx-utils kmod-i2c-mux-pca954x kmod-leds-turris-omnia
   IMAGES := $$(DEVICE_IMG_PREFIX)-sysupgrade.img.gz omnia-medkit-$$(DEVICE_IMG_PREFIX)-initramfs.tar.gz
   IMAGE/$$(DEVICE_IMG_PREFIX)-sysupgrade.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
   IMAGE/omnia-medkit-$$(DEVICE_IMG_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
index 2700e2b1593d96d9626fefa6c33c6363c5c36c54..311cc07c7f4226e17883254fabd82f2f27f2013d 100644 (file)
@@ -15,3 +15,19 @@ define KernelPackage/linkstation-poweroff/description
 endef
 
 $(eval $(call KernelPackage,linkstation-poweroff))
+
+
+define KernelPackage/leds-turris-omnia
+   SUBMENU:=$(LEDS_MENU)
+   TITLE:=LED support for CZ.NIC's Turris Omnia
+   DEPENDS:=@TARGET_mvebu_cortexa9
+   KCONFIG:=CONFIG_LEDS_TURRIS_OMNIA
+   FILES:=$(LINUX_DIR)/drivers/leds/leds-turris-omnia.ko
+   AUTOLOAD:=$(call AutoLoad,60,leds-turris-omnia,1)
+endef
+
+define KernelPackage/leds-turris-omnia/description
+   This option enables support for the LEDs of the CZ.NIC Turris Omnia.
+endef
+
+$(eval $(call KernelPackage,leds-turris-omnia))