gre: use alternative way to check if kernel support is enabled
authorAlin Nastac <alin.nastac@gmail.com>
Tue, 23 Feb 2021 12:05:09 +0000 (13:05 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 13 Mar 2021 19:58:55 +0000 (20:58 +0100)
When necessary support is built in kernel, gre protocol support is
not enabled in netifd.

Signed-off-by: Alin Nastac <alin.nastac@gmail.com>
package/network/config/gre/Makefile
package/network/config/gre/files/gre.sh

index b16dd72cde483a1e9880f686d6bc72a1a34a2b4b..c920abeb0d1dee93ed48c13bce555088f7fdf421 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
-PKG_RELEASE:=12
+PKG_RELEASE:=13
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index eb3df5b48c874c7e14b32bd53bb27a8ff0854684..b57d5d4cdb3434467184aa08da77e6d0cdf3637c 100755 (executable)
@@ -291,8 +291,6 @@ proto_grev6tap_init_config() {
 }
 
 [ -n "$INCLUDE_ONLY" ] || {
-       [ -f /lib/modules/$(uname -r)/gre.ko ] && add_protocol gre
-       [ -f /lib/modules/$(uname -r)/gre.ko ] && add_protocol gretap
-       [ -f /lib/modules/$(uname -r)/ip6_gre.ko ] && add_protocol grev6
-       [ -f /lib/modules/$(uname -r)/ip6_gre.ko ] && add_protocol grev6tap
+       [ -d /sys/module/ip_gre ] && { add_protocol gre; add_protocol gretap; }
+       [ -d /sys/module/ip6_gre ] && { add_protocol grev6; add_protocol grev6tap; }
 }