bcm27xx: add support for RPI CM4 and RPI 400
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 18 Feb 2021 22:07:05 +0000 (23:07 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 18 Feb 2021 22:43:18 +0000 (23:43 +0100)
Support added to bcm2709 (32 bits) and bcm2711 (64 bits).

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm27xx/base-files/etc/board.d/02_network
target/linux/bcm27xx/image/Makefile

index 36c8c5df1afaaaa8675a7f152970bc5f923dacec..665504a3fc5eeadf61b2004ff364507f817a68e3 100755 (executable)
@@ -18,6 +18,8 @@ raspberrypi,2-model-b |\
 raspberrypi,2-model-b-rev2 |\
 raspberrypi,3-model-b |\
 raspberrypi,3-model-b-plus |\
+raspberrypi,400 |\
+raspberrypi,4-compute-module |\
 raspberrypi,4-model-b)
        ucidef_set_interface_lan "eth0"
        ;;
index fbef5ecbf4fca9fc562fc33d3f912c6818fdf1d1..30b3e83cf63a81f5d396a82b3119f1afe8fdc2fc 100644 (file)
@@ -90,19 +90,19 @@ define Device/rpi-2
   DEVICE_ALT0_MODEL := 3B/3B+/3CM
   DEVICE_ALT0_VARIANT := (32bit)
   DEVICE_ALT1_VENDOR := Raspberry Pi
-  DEVICE_ALT1_MODEL := 4B
+  DEVICE_ALT1_MODEL := 4B/400/4CM
   DEVICE_ALT1_VARIANT := (32bit)
   DEVICE_DTS := \
        bcm2709-rpi-2-b bcm2710-rpi-2-b \
        bcm2710-rpi-3-b bcm2710-rpi-3-b-plus \
-       bcm2711-rpi-4-b \
-       bcm2710-rpi-cm3
+       bcm2711-rpi-4-b bcm2711-rpi-400 \
+       bcm2710-rpi-cm3 bcm2711-rpi-cm4
   SUPPORTED_DEVICES := \
        rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm \
        raspberrypi,2-model-b raspberrypi,2-model-b-rev2 \
        raspberrypi,3-model-b raspberrypi,3-model-b-plus \
        raspberrypi,3-compute-module raspberrypi,compute-module-3 \
-       raspberrypi,4-model-b
+       raspberrypi,400 raspberrypi,4-compute-module raspberrypi,4-model-b
   DEVICE_PACKAGES := \
        cypress-firmware-43430-sdio \
        cypress-nvram-43430-sdio-rpi-3b \
@@ -144,11 +144,16 @@ ifeq ($(SUBTARGET),bcm2710)
 endif
 
 define Device/rpi-4
-  DEVICE_MODEL := 4B
+  DEVICE_MODEL := 4B/400/4CM
   DEVICE_VARIANT := (64bit)
   KERNEL_IMG := kernel8.img
-  DEVICE_DTS := broadcom/bcm2711-rpi-4-b
+  DEVICE_DTS := \
+       broadcom/bcm2711-rpi-400 \
+       broadcom/bcm2711-rpi-4-b \
+       broadcom/bcm2711-rpi-cm4
   SUPPORTED_DEVICES := \
+       raspberrypi,400 \
+       raspberrypi,4-compute-module \
        raspberrypi,4-model-b
   DEVICE_PACKAGES := \
        cypress-firmware-43455-sdio \