add kmod-net-e100 and kmod-pcmcia packages, fix typo
authorNicolas Thill <nico@openwrt.org>
Tue, 1 Nov 2005 04:38:19 +0000 (04:38 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 1 Nov 2005 04:38:19 +0000 (04:38 +0000)
SVN-Revision: 2310

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-net-e100.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-pcmcia-core.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile

index 5fca0f0698eace3d36afda2e9e4c21d0a22e02ef..6f4803ff7384d18672046f43c8934cb6b5e1979b 100644 (file)
@@ -365,6 +365,12 @@ config BR2_PACKAGE_KMOD_NET_AIRO
          This package contains the airo.o kernel module.
          
 
+config BR2_PACKAGE_KMOD_E100
+       tristate "kmod-net-e100.................. Intel(R) PRO/100+ cards kernel support"
+       default m
+       help
+         Intel(R) PRO/100+ cards kernel support
+
 config BR2_PACKAGE_KMOD_B44
        tristate "kmod-net-b44................... Broadcom 44XX, 47XX ethernet driver"
        default m
@@ -470,10 +476,16 @@ config BR2_PACKAGE_KMOD_NET_PRISM54
          This package contains the prism54.o kernel module.
          
 
+comment "PCMCIA/CardBus support --------"
+
+config BR2_PACKAGE_KMOD_PCMCIA_CORE
+       tristate "kmod-pcmcia-core............... PCMCIA/CardBus support"
+       default m
+
 comment "USB support -------------------"
 
 config BR2_PACKAGE_KMOD_USB
-       tristate "kmod-usb....................... USB support"
+       tristate "kmod-usb-core.................. USB support"
        default m
 
 config BR2_PACKAGE_KMOD_USB_UHCI
diff --git a/openwrt/target/linux/control/kmod-net-e100.control b/openwrt/target/linux/control/kmod-net-e100.control
new file mode 100644 (file)
index 0000000..bd5537b
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-e100
+Priority: optional
+Section: sys
+Description: Intel(R) PRO/100+ cards kernel support
diff --git a/openwrt/target/linux/control/kmod-pcmcia-core.control b/openwrt/target/linux/control/kmod-pcmcia-core.control
new file mode 100644 (file)
index 0000000..3e137ea
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-pcmcia-core
+Priority: optional
+Section: sys
+Description: PCMCIA/CardBus kernel support
index 64e52cc1b58dae5a150ecd7c998bc499cf5edf48..05e4ef63dca8dc252d6975ca0b2bb3229b8df42b 100644 (file)
@@ -211,6 +211,10 @@ $(eval $(call KMOD_template,NET_B44,net-b44,\
        $(MODULES_DIR)/kernel/drivers/net/b44.o \
 ,CONFIG_B44,,10,b44))
 
+$(eval $(call KMOD_template,NET_E100,net-e100,\
+       $(MODULES_DIR)/kernel/drivers/net/e100.o \
+,CONFIG_E100,,10,e100))
+
 $(eval $(call KMOD_template,NET_HERMES,net-hermes,\
        $(MODULES_DIR)/kernel/drivers/net/wireless/hermes.o \
        $(MODULES_DIR)/kernel/drivers/net/wireless/orinoco.o \
@@ -233,6 +237,15 @@ $(eval $(call KMOD_template,NET_PRISM54,net-prism54,\
 ,CONFIG_PRISM54,,10,prism54))
 
 
+# PCMCIA/CardBus
+
+$(eval $(call KMOD_template,PCMCIA_CORE,pcmcia-core,\
+       $(MODULES_DIR)/kernel/drivers/pcmcia/pcmcia_core.o \
+       $(MODULES_DIR)/kernel/drivers/pcmcia/ds.o \
+       $(MODULES_DIR)/kernel/drivers/pcmcia/yenta_socket.o \
+,CONFIG_PCMCIA,,50,pcmcia_core))
+
+
 # USB
 
 $(eval $(call KMOD_template,USB,usb-core,\