kirkwood: Add support for Iomega StorCenter ix2-200
authorJohn Crispin <john@openwrt.org>
Wed, 26 Nov 2014 09:00:48 +0000 (09:00 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 26 Nov 2014 09:00:48 +0000 (09:00 +0000)
Signed-off-by: Richard Kunze <richard.kunze@web.de>
SVN-Revision: 43391

target/linux/kirkwood/image/Makefile
target/linux/kirkwood/profiles/110-nas.mk

index 3852cacd3a1497b8d52990dc75029ba7ef5255cd..ec1b9780ae0b8af235af621c5737d18d0f6935be 100644 (file)
@@ -135,6 +135,9 @@ Image/InstallKernel/Template/ICONNECT=$(call Image/InstallKernel/Template,iconne
 Image/BuildKernel/Template/POGOE02=$(call Image/BuildKernel/Template,pogo_e02)
 Image/InstallKernel/Template/POGOE02=$(call Image/InstallKernel/Template,pogo_e02)
 
+Image/BuildKernel/Template/IOMEGA_IX2_200=$(call Image/BuildKernel/Template,iomega_ix2_200)
+Image/InstallKernel/Template/IOMEGA_IX2_200=$(call Image/InstallKernel/Template,iomega_ix2_200)
+
 define Image/BuildKernel
        $(call Image/BuildKernel/Template/$(PROFILE))
 endef
index eff59528a04d8180f26c8cbd27caccd654320a54..1bd188c11e472cb265b124293560ef774917158e 100644 (file)
@@ -84,3 +84,22 @@ POGOE02_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
 POGOE02_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,POGOE02))
+
+
+define Profile/IOMEGA_IX2_200
+  NAME:=Iomega StorCenter ix2-200
+  PACKAGES:= \
+       kmod-ata-core kmod-ata-marvell-sata \
+       kmod-usb2 kmod-usb-storage \
+       uboot-envtools
+endef
+
+define Profile/IOMEGA_IX2_200/Description
+ Package set compatible with Iomega StorCenter ix2-200 board.
+endef
+
+IOMEGA_IX2_200_UBIFS_OPTS:="-m 512 -e 15872 -c 2048"
+IOMEGA_IX2_200_UBI_OPTS:="-m 512 -p 16384 -s 256"
+
+$(eval $(call Profile,IOMEGA_IX2_200))
+