uboot-at91: Add support for SAMA5D3 Xplained board
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Wed, 13 Sep 2017 18:51:20 +0000 (11:51 -0700)
committerJohn Crispin <john@phrozen.org>
Wed, 20 Sep 2017 07:01:24 +0000 (09:01 +0200)
Add support for SAMA5D3 Xplained board and options to select & build
u-boot configs for different media storage.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
package/boot/uboot-at91/Makefile

index 68e4ba498bc3eaea81a98857072f7108b3a0f578..2c95377b0fb0f95cc7cabd0ba2b7ec429b303136 100644 (file)
@@ -30,9 +30,23 @@ define U-Boot/at91sam9x5ek_nandflash
   BUILD_SUBTARGET:=legacy
 endef
 
   BUILD_SUBTARGET:=legacy
 endef
 
+define uboot/sama5d3_xplained_nandflash
+  TITLE:=U-Boot for the SAMA5D3 Xplained board (NandFlash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
+define uboot/sama5d3_xplained_mmc
+  TITLE:=U-Boot for the SAMA5D3 Xplained board (SDcard)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
 UBOOT_TARGETS := \
        at91sam9m10g45ek_nandflash \
 UBOOT_TARGETS := \
        at91sam9m10g45ek_nandflash \
-       at91sam9x5ek_nandflash
+       at91sam9x5ek_nandflash \
+    sama5d3_xplained_nandflash \
+    sama5d3_xplained_mmc
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \